Opened 10 years ago

Closed 10 years ago

#3009 closed bug (fixed)

BePDF crashes on launch

Reported by: bbjimmy Owned by: axeld
Priority: normal Milestone: R1
Component: - General Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

hrev28387 and BePDF version 1.1.1

BePDF crashes on launch ...

[tcsetpgrp failed in terminal_inferior: Invalid Argument] [Switching to team /boot/apps/BePDF/BePDF (2236) thread BePDF (2236)] 0xffff0104 in ?? ()

Change History (7)

comment:1 Changed 10 years ago by bbjimmy

I ran the haiku.image in qemu on my ubuntu partition and BePDF launched ok. I then re-installed the build to my hard disk and BePDF still does not launch. It seems that this error has something to do with my hardware vs the emulated hardware used by qemu.

comment:2 Changed 10 years ago by umccullough

Is it a multi-core machine by chance?

You should probably post the machine specs if you believe it's related to the hardware configuration.

comment:3 in reply to:  2 ; Changed 10 years ago by bbjimmy

Replying to umccullough:

Is it a multi-core machine by chance?

You should probably post the machine specs if you believe it's related to the hardware configuration.

from ZetaPC-Info

CPU Number: 1

System Type: Uniprocessor

CPU Brand: AMD (Advanced Micro Devices)

CPU Vendor ID: AuthenticAMD

CPU String: AMD Sempron(tm) 2400+

CPU Type: Original OEM Processor

CPU operating mode: 32 Bit

x86 Family: 786

Cpu Model: Athlon

Cpu Series: XP/MP/Sempron (Thoroughbred)

Cpu Code: 4456

Cpu Revision: 1665

Standard Family: 6

Standard Model: 8

Standard Stepping: 1

Extended Family: 7

Extended Model: 8

Extended Stepping: 1

MMX: Yes

MMX+: Yes

SSE: Yes

SSE2: No

SSE3: No

3DNow!: Yes

3DNow!+: Yes

3DNow!PRO: Yes

x86-64/EMT64: No

Cpu speed in Mhz: 1666

##################################################

Devices

North Bridge: VIA - - CPU to PCI Bridge Vendor: 0x1106 - Device: 0x3205

South Bridge: VIA - VT8235 - PCI to ISA Bridge Vendor: 0x1106 - Device: 0x3177

Video Card: VIA - KM400 - VIA Technologies, Inc. VT8378 [S3 UniChrome] Graphics Adapter Vendor: 0x1106 - Device: 0x7205

Sound Card: VIA - VT8233/33A/8235/8237 - AC97 Enhanced Audio Controller Vendor: 0x1106 - Device: 0x3059

Ethernet Card: Accton - SMC EN5030B - 12078a1 107d Vendor: 0x1113 - Device: 0x1211

##################################################

Resources

Media: RAM Memory

Size(MB): 448.0

Used(MB): 168.5

Free(MB): 279.5

Used on total Size: 37.6%

comment:4 in reply to:  3 Changed 10 years ago by bbjimmy

hrev28415 ... BePDF works again!

comment:5 Changed 10 years ago by korli

this bug looks like the bug #2805 though.

comment:6 Changed 10 years ago by bbjimmy

Later versions have resolved the issue. This is no longer reproducible. Please Close this ticket.

comment:7 Changed 10 years ago by korli

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.