Opened 11 years ago

Closed 11 years ago

#3017 closed bug (duplicate)

vm_page_fault: unhandled page fault in kernel space at 0x0904254e, ip 0x80035bfb

Reported by: anode Owned by: axeld
Priority: normal Milestone: R1
Component: System/Kernel Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

My laptop has stopped booting haiku since a little over a week and a half ago. Booting sometimes just freezes at the red rocket icon and other times I get the attatched KDL. The revision that first broke booting on my laptop was hrev28244 although I am unsure if the KDL I am recieving now is related to that revision. This is on an hp pavillion dv9843cl laptop, hrev28415.

(as a side note, my laptop also experiences bug #2680 although I doubt it has any effect on this bug)

Attachments (7)

kdl.jpg (128.7 KB) - added by anode 11 years ago.
kdl1.zip (217.3 KB) - added by anode 11 years ago.
kdl2.zip (223.9 KB) - added by anode 11 years ago.
kdl3.zip (222.7 KB) - added by anode 11 years ago.
kdl4.zip (218.9 KB) - added by anode 11 years ago.
screen_debug.zip (328.2 KB) - added by anode 11 years ago.
screen_debug_kdl.zip (220.7 KB) - added by anode 11 years ago.

Download all attachments as: .zip

Change History (14)

Changed 11 years ago by anode

Attachment: kdl.jpg added

comment:1 Changed 11 years ago by axeld

Are you booting via USB, SATA, or IDE?

And did I understand correctly that Haiku used to work on this laptop?

Have you turned on APM or ACPI?

BTW it's obviously 0x80035bfb, not 0x00...

Is it still reproducible with a current revision (hrev28517 or newer)?

comment:2 Changed 11 years ago by axeld

Summary: vm_page_fault: unhandled page fault in kernel space at 0x0904254e, ip 0x00035bfbvm_page_fault: unhandled page fault in kernel space at 0x0904254e, ip 0x80035bfb

comment:3 Changed 11 years ago by anode

I am booting via USB and yes, haiku did previously work on this laptop. I have not turned on APM or ACPI (just default settings with all optional packages and an alternate keymap/timezone). I tried to reproduce the bug with hrev28522 and it seems the original kdl no longer occurs but haiku still fails to boot (stopping and the red rocket icon) and gives a number of different kdls with different attempts. I commented out the panic that is thrown in #2680 so that I could get the screen debug output which seems to be consistent. I've attatched a zip with the various kdls and the screen debug. Sorry for the low quality images, its unfortunetly the best camera I can get my hands on at the momment ;)

Changed 11 years ago by anode

Attachment: kdl1.zip added

Changed 11 years ago by anode

Attachment: kdl2.zip added

Changed 11 years ago by anode

Attachment: kdl3.zip added

Changed 11 years ago by anode

Attachment: kdl4.zip added

Changed 11 years ago by anode

Attachment: screen_debug.zip added

Changed 11 years ago by anode

Attachment: screen_debug_kdl.zip added

comment:4 Changed 11 years ago by anode

I just tried booting hrev28596 and the issue appears to be fixed.

comment:5 Changed 11 years ago by axeld

So you obviously have a dual core laptop? Because then it would just be the same problem that I fixed in #2902.

comment:6 Changed 11 years ago by anode

Yes, its a dual core laptop and this does look like a duplicate of #2092

comment:7 Changed 11 years ago by axeld

Resolution: duplicate
Status: newclosed

Okay, thanks for the update, and all the KDL images :-)

Note: See TracTickets for help on using tickets.