Opened 11 years ago

Closed 10 years ago

#3078 closed bug (duplicate)

VisualBoyAdvance doesn't work

Reported by: Denise Purple Owned by: axeld
Priority: normal Milestone: R1
Component: - General Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

I have tried to run VisualBoyAdvance, but it doesn't work. Its BeOS version is command-line based. This is the terminal output I get while trying to run it:

~> /boot/home/VisualBoyAdvance-1.5-SDL-BeOS-x86/VisualBoyAdvance runtime_loader: elf_resolve_symbol: found symbol 'debugger' in shared image but wrong type resolve symbol "debugger" returned: -2147478780 runtime_loader: troubles relocating: 0x80001304 (image: /boot/beos/system/lib/libbe.so, libbe.so)


  • How I run Haiku: I run the pre-alpha raw image from haiku-files under emulation. The emulator is VirtualBox. I convert the raw image to a .vdi file that VirtualBox can use, with the command "VBoxManage convertdd haiku-alpha.image haiku-alpha.vdi".
  • Host specs:

Processor: AMD Athlon XP 2,9 Ghz

RAM: 512MB

GPU: Nvidia Geforce 7600, 256MB

Host OS: Ubuntu Intrepid 8.10 (A GNU/Linux distribution)

  • Haiku revision: 28506
  • How to reproduce: Just run the executable file in the terminal. Every time I do, the same thing happens. I have tried in many revisions of Haiku, both under emulation and in real hardware with the same result.
  • About VisualBoyAdvance: It is a GBA (GameBoy Advance) emulator for running GBA games. It is open source and available for Windows, BeOS and GNU/Linux so far.
  • Other information: The version of VisualBoyAdvance tested now was 1.5, but it seems like all versions react the same. When checking the README, it recommended using GCC3 when compiling from source. The file I downloaded was pre-compiled though. I don't know what the binary was compiled with, or if it even matters.

So, my first bug report! I tried to be as accurate as I could, but if I missed something just tell me. Thanks!

Change History (1)

comment:1 Changed 10 years ago by scottmc

Resolution: duplicate
Status: newclosed

dupe of #2647

Note: See TracTickets for help on using tickets.