Opened 10 years ago

Closed 4 years ago

#3079 closed bug (duplicate)

ice1712 driver produces distorted output

Reported by: tigerdog Owned by: jerl1
Priority: normal Milestone: R1
Component: Drivers/Audio/ice1712 Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

to reproduce: -build and install ice1712 driver from haiku source tree -restart media server -play audio file

experienced behavior: audio is distorted. sounds like 16-bit audio being played through 24-bit DAC. sometimes sounds like wrong sample rate. I believe card is not being properly initialized with correct sample rate and bit depth. Also, these settings are not present in Haiku media control panel entry for this device. Panel entries appear correctly under R5, BONE and Zeta. Driver works under R5, BONE and Zeta at least for playback.

expected behavior: sweet, melodious audio output

Filing as Drivers/Audio bug but could also be Preferences/Media

Change History (4)

comment:1 Changed 8 years ago by diver

Component: Drivers/AudioDrivers/Audio/ice1712

comment:2 Changed 7 years ago by mmadia

Owner: changed from korli to jerl1
Status: newassigned

comment:3 Changed 4 years ago by jerl1

Duplicate of #9074.

Patch submited with ticket #9074

comment:4 Changed 4 years ago by jerl1

Resolution: duplicate
Status: assignedclosed
Note: See TracTickets for help on using tickets.