Opened 11 years ago

Closed 10 years ago

Last modified 8 years ago

#3111 closed bug (fixed)

[auich] PANIC: page fault but interrupts were disabled.

Reported by: diver Owned by: korli
Priority: normal Milestone: R1
Component: Drivers/Audio/auich Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

While trying to reproduce #3110 I get kdl. I'm running VirtualBox 2.0.2 with auich driver.

Attachments (2)

kdl_new.png (68.8 KB) - added by diver 11 years ago.
hmulti.png (101.8 KB) - added by diver 11 years ago.
hmulti_audio.media_addon crash

Download all attachments as: .zip

Change History (15)

Changed 11 years ago by diver

Attachment: kdl_new.png added

Changed 11 years ago by diver

Attachment: hmulti.png added

hmulti_audio.media_addon crash

comment:1 Changed 11 years ago by diver

Summary: [auich] PANIC: page fault but interrupt were disabled.[auich] PANIC: page fault but interrupts were disabled.

comment:2 Changed 11 years ago by diver

I can reproduce this.

comment:3 Changed 11 years ago by korli

Tried and couldn't reproduce yet. Did you choose ALSA + ICH 97 ? Did you customize something on the VM ?

comment:4 Changed 11 years ago by diver

Oh, I used Null Audio drver + ICH 97, that's why i can't hear any sound :)
I set OS type to freebsd (I've heard that haiku worked better in vmware if OS was set to freebsd , don't know if it true).

comment:5 Changed 11 years ago by korli

So you heard something on vmware, then you apply it on virtualbox :)

comment:6 Changed 11 years ago by korli

Could you reproduce as of hrev28887 please ?

comment:7 Changed 11 years ago by diver

I'll try.

comment:8 Changed 10 years ago by korli

Did you have the opportunity to try ?

comment:9 Changed 10 years ago by diver

Sorry, not yet.

comment:10 Changed 10 years ago by diver

Since then I've updated VirtualBox from 2.0.2 to 2.1.2 and now when I try to reproduce this issue VirtualBox with haiku just close itself.

comment:11 Changed 10 years ago by diver

I can't reproduce it since I've moved to VirtualBox 3.0.4.

comment:12 Changed 10 years ago by korli

Resolution: fixed
Status: newclosed

comment:13 Changed 8 years ago by diver

Component: Drivers/AudioDrivers/Audio/AUICH
Note: See TracTickets for help on using tickets.