Opened 11 years ago

Closed 11 years ago

#3119 closed bug (invalid)

BRoster::Launch(app_sig) fails if the app has never been run before

Reported by: anevilyak Owned by: axeld
Priority: normal Milestone: R1
Component: Kits/Application Kit Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

As a simple example, if you build IM Kit on Haiku and then install its deskbar icon, its "Start im_server" option does nothing. However, if you manually start the im_server and then quit it again, Start im_server works. Its code is very simple:

be_roster->Launch(IM_SERVER_SIG);

Note that after freshly installing im_server, its mime type is set correctly and it can be found using query BEOS:APP_SIG from Terminal, so it would seem BRoster is bailing out early without ever trying to query the disk for it.

Change History (1)

comment:1 by anevilyak, 11 years ago

Resolution: invalid
Status: newclosed

Seems there was something else going on here, I can't reproduce it any more now that I've rebuilt and tried adding debugging code and such.

Note: See TracTickets for help on using tickets.