Opened 11 years ago

Closed 8 years ago

#3120 closed bug (fixed)

3com Combo nic doesn't work

Reported by: apprentice Owned by: axeld
Priority: normal Milestone: R1
Component: Drivers/Network/3com Version: R1/Development
Keywords: Cc: adek336@…, mattmadia@…
Blocked By: Blocking:
Has a Patch: yes Platform: x86

Description

Just read the attached syslog...

Attachments (7)

syslog (197.2 KB) - added by apprentice 11 years ago.
3com.diff.1.diff (534 bytes) - added by Adek336 11 years ago.
3com-diff.jpg (297.8 KB) - added by apprentice 11 years ago.
haiku.syslog (60.1 KB) - added by apprentice 11 years ago.
3com-forcebt-disablemmio.diff (3.8 KB) - added by Adek336 11 years ago.
3com.1.diff (820 bytes) - added by Adek336 11 years ago.
haiku.jpg (367.9 KB) - added by apprentice 11 years ago.

Download all attachments as: .zip

Change History (38)

Changed 11 years ago by apprentice

Attachment: syslog added

comment:1 Changed 11 years ago by richienyhus

duplicate of #2954

comment:2 Changed 11 years ago by stippi

Seems so. I am closing the other one though, since this one has got the syslog and mentions only one issue.

comment:3 Changed 11 years ago by Adek336

Cc: adek336@… added

Changed 11 years ago by Adek336

Attachment: 3com.diff.1.diff added

comment:4 Changed 11 years ago by Adek336

When you'll feel like testing, let me know what traced contains with this patch.

Changed 11 years ago by apprentice

Attachment: 3com-diff.jpg added

comment:5 Changed 11 years ago by apprentice

I applied the patch and added the trace output.

comment:6 Changed 11 years ago by mmadia

Cc: mattmadia@… added

comment:7 Changed 11 years ago by Adek336

You've got 3c900 10Mbps Combo [Boomerang] (vendor/device 10b7/9001) and it doesn't attach
I've got 3c900B-Combo Etherlink XL Combo [Cyclone] (vendor/device 10b7/9005) and it attaches and sends/receives but I don't get an IP.

comment:8 Changed 11 years ago by Adek336

It gets the IP when the on-board via rhine chip is disabled.

comment:9 Changed 11 years ago by Adek336

What does "ints" in KDL say, does removing usb devices or disabling *HCI help?

comment:10 Changed 11 years ago by Adek336

Could you also try the fix proposed http://unix.derkeiler.com/Mailing-Lists/FreeBSD/current/2004-04/1049.html

       if (did == TC_DEVICEID_TORNADO_10_100BT_920B ||
           did == TC_DEVICEID_TORNADO_10_100BT_920B_WNM)
                sc->xl_flags |= XL_FLAG_PHYOK;

        switch (did) {
+       case TC_DEVICEID_BOOMERANG_10BT_COMBO: /* added by rodrigc */
        case TC_DEVICEID_BOOMERANG_10_100BT: /* 3c905-TX */
        case TC_DEVICEID_HURRICANE_575A:
        case TC_DEVICEID_HURRICANE_575B:
        case TC_DEVICEID_HURRICANE_575C:
                  sc->xl_flags |= XL_FLAG_NO_MMIO; 

comment:11 Changed 11 years ago by apprentice

I disabled usb & acpi & apm and about everything else you can disable from the bios - and also acpi and apic - from haiku safe mode options and still be able to boot but with the 3com diff it still crashes. I added the ints output but can't see anything network related in it. I'll try the fix when I get enough time to test it.

comment:12 Changed 11 years ago by apprentice

Sorry, can't attach the image... trac complains something about not being able to give an unique name to the file.

comment:13 Changed 11 years ago by richienyhus

Trac is playing up right now. Try upload it to a external site, for the time being that is.

comment:14 Changed 11 years ago by Adek336

Could you try that patch?
Your card doesn't support MMIO but Haiku uses MMIO for you card anyway, the patch above disables MMIO for your model; unless there is some other problem, your card will now work.

comment:15 Changed 11 years ago by apprentice

I apologize for the long delay but I haven't had enough time lately to devote to this bug.

Adek336, thanks for the patch! It worked and ifconfig now lists /dev/net/3com/0. Networking still doesn't work, but I suspect the reason is that the freebsd driver defaults to using BNC port instead of TP and currently it seems that there is now way of changing the port. Maybe the driver should divert from the freebsd driver just by defaulting to TP. This would be a reasonable and quick fix and honestly, who uses BNC anymore anyway.

comment:16 Changed 11 years ago by Adek336

You haven't had /dev/net/3com/0 before if I recall correctly, right? That's great news, as it means we've progressed a lot with this patch!

I'll take a look at what I can do with TP/BNC.

comment:17 Changed 11 years ago by apprentice

Confirmed, syslog says: ifmedia_set: setting to Ethernet 10base2/BNC

Changed 11 years ago by apprentice

Attachment: haiku.syslog added

Changed 11 years ago by Adek336

comment:18 Changed 11 years ago by Adek336

Could you check?

comment:19 Changed 11 years ago by apprentice

checked and tested, the latest patch solves the problem completely. I get an IP and ping works. Thanks!

comment:20 Changed 11 years ago by stippi

Cool. Nice work, guys! Am I correct in assuming that this patch cannot be applied as is?

comment:21 Changed 11 years ago by Adek336

Great[[br]] Indeed, the patch should be reworked a little bit so it uses the workaround only for this device id.

Changed 11 years ago by Adek336

Attachment: 3com.1.diff added

comment:22 Changed 11 years ago by Adek336

Could you please check this new patch?

Changed 11 years ago by apprentice

Attachment: haiku.jpg added

comment:23 Changed 11 years ago by apprentice

checked it. I think the screenshot speaks for itself. Again, thanks a _lot_

comment:24 in reply to:  description Changed 9 years ago by markh

Version: R1/pre-alpha1R1/alpha2

It seems I'm running into the same problem with this card in alpha 2. Is the fix proposed in this ticket not in the tree yet?

comment:25 Changed 9 years ago by markh

Can someone have a look at if the patch is in the tree or if it can be added as is?

comment:26 Changed 9 years ago by mmadia

Has a Patch: set

comment:27 in reply to:  21 ; Changed 9 years ago by mmadia

Replying to Adek336:

Great[[br]] Indeed, the patch should be reworked a little bit so it uses the workaround only for this device id.

Is http://dev.haiku-os.org/attachment/ticket/3120/3com.1.diff the reworked patch, ready to be committed?

comment:28 in reply to:  27 Changed 9 years ago by Adek336

No, the second hunk is clearly out of place; I can't rework it as I don't have the hardware anymore.

comment:29 Changed 8 years ago by modeenf

Had a look now and the patch are good as is. Same lines still exist in the same places (file version hrev34822)

comment:30 Changed 8 years ago by diver

Component: Drivers/NetworkDrivers/Network/3com

comment:31 Changed 8 years ago by anevilyak

Resolution: fixed
Status: newclosed
Version: R1/alpha2R1/Development

Applied in hrev42952. Thanks!

Note: See TracTickets for help on using tickets.