Opened 11 years ago

Closed 11 years ago

#3126 closed bug (fixed)

vm_page_fault at first keypress in Terminal app

Reported by: bhaible Owned by: bonefish
Priority: critical Milestone: R1
Component: Drivers/TTY Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking: #2223
Has a Patch: no Platform: All

Description

The kernel debugger is activated.

To reproduce: Fresh reboot. Launch the Terminal application. Type telnet www.heise.de 80 <RET> It connects to this web server. Type GET / <RET> The cursor goes back to column 0, but nothing is printed. Close the Terminal application by clicking on its close button (top left yellow button). Launch the Terminal application. Type the Up arrow key from the arrows keypad.

Attachments (2)

haiku-crash1.png (35.7 KB) - added by bhaible 11 years ago.
screenshot after typing Up arrow
haiku-crash1-stack.png (49.0 KB) - added by bhaible 11 years ago.
kernel stack trace

Download all attachments as: .zip

Change History (6)

Changed 11 years ago by bhaible

Attachment: haiku-crash1.png added

screenshot after typing Up arrow

Changed 11 years ago by bhaible

Attachment: haiku-crash1-stack.png added

kernel stack trace

comment:1 Changed 11 years ago by axeld

Component: SystemDrivers/TTY
Owner: changed from axeld to bonefish
Priority: normalcritical

comment:2 Changed 11 years ago by bonefish

Status: newassigned

Can reproduce the problem. Will look into it tomorrow.

comment:3 Changed 11 years ago by bonefish

Resolution: fixed
Status: assignedclosed

Fixed in hrev28651.

comment:4 Changed 11 years ago by axeld

Blocking: 2223 added

(In #2223) Duplicate of #3126 which contains a reliable method on how to reproduce it.

Note: See TracTickets for help on using tickets.