Opened 10 years ago

Closed 8 years ago

Last modified 9 months ago

#3134 closed bug (fixed)

KDL (page daemon) when booting on Lenovo S9

Reported by: mr. Noisy Owned by: marcusoverhagen
Priority: normal Milestone: R1
Component: Drivers/Disk Version:
Keywords: Cc:
Blocked By: Blocking: #2488, #3988
Has a Patch: no Platform: x86

Description

Boot hangs up with KDL after 4th (disk with leaf) icon: PANIC: page fault, but interrupts were disabled Touching address 0xccccccd8 from eip 0x8004992d

Thread 8 "page daemon" (in some cases "Thread 7 page write" Running on CPU 0

Happens with hrev28641 (pre-alpha image) Hardware specs: Intel Atom N270 1.6GHz, 1GB RAM, HDD 120GB Boot media: USB Flash Drive Kingston DataTraveler 2GB

Change History (14)

comment:1 Changed 10 years ago by mr. Noisy

Enabling AHCI Compliant mode solves the problem.

comment:2 Changed 10 years ago by umccullough

You should be able to replace the "ide" bus_manager with the newer (yet, incomplete and slower) "ata" bus_manager to get past this error (see ticket #2349 where I was able to get past this same problem that way). You'll need to modify a jamfile and compile a new image to do this.

The ide bus_manager has known issues and it is planned to be replaced by the ata bus_manager (hopefully before alpha).

comment:3 Changed 10 years ago by umccullough

Component: - GeneralDrivers/Disk
Owner: changed from axeld to marcusoverhagen

comment:4 Changed 10 years ago by umccullough

Just noted your KDL was in a different thread, but still I wouldn't be surprised if it was related to the bus_manager.

comment:5 Changed 10 years ago by mmlr

Blocking: 3988 added

(In #3988) I actually meant #3134, which was reported by the same person as this one. All three are the same though, so I'll close two of them as duplicate.

comment:6 Changed 10 years ago by mmlr

Blocking: 2488 added

(In #2488) Closing as duplicate of #3134 as that one has more info.

comment:7 Changed 10 years ago by FSV

I have this error too: PANIC: page fault, but interrupts were disabled. Touching address 0xccccccd8 from eip 0x8004ed91

Changing in BIOS SATA mode from IDE to AHCI was resolved this problem on my system: Core2Duo E4500 / 2 GB RAM / Asus P5B (P965, ICH8) / Radeon X1950Pro / 2 SATA HDD / PATA DVD+RW

comment:8 Changed 10 years ago by mr.Noisy

In my case, this change also solves the problem, but after that the hard disk is not detected by BIOS. Certainly Windows does not boot after that. Hauku couldn't find it in DriveSetup.

comment:9 Changed 10 years ago by mr.Noisy

It concerns the computer described in #3988. Not Lenovo S9.

comment:10 Changed 8 years ago by scottmc

Can you recheck this with a recent Haiku build? It may have been fixed recently.

comment:11 Changed 8 years ago by scottmc

Blocking: 7665 added

comment:12 Changed 8 years ago by mr.Noisy

Yeah, the problem is gone. Thanks!

comment:13 Changed 8 years ago by umccullough

Resolution: fixed
Status: newclosed

Thanks for verifying!

comment:14 Changed 9 months ago by waddlesplash

Blocking: 7665 removed
Note: See TracTickets for help on using tickets.