Opened 11 years ago

Closed 5 years ago

Last modified 16 months ago

#3144 closed bug (invalid)

Dell Latitude C800: NMI during boot

Reported by: Adek336 Owned by: axeld
Priority: normal Milestone: R1
Component: System/Kernel Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I get NMI panics at various moments during boot. I can continue through them.

Attachments (4)

img_1027.jpg (92.8 KB ) - added by Adek336 11 years ago.
NMI during the handling of a panic in thread picasso
img_1028.jpg (74.9 KB ) - added by Adek336 11 years ago.
NMI in draw_cursor_ _F11
img_1031.jpg (77.9 KB ) - added by Adek336 11 years ago.
NMI panic during the handling of another panic in thread net_server
img_1043.jpg (29.9 KB ) - added by Adek336 11 years ago.
Failure to show KDL prompt: possibly due to NMI in the kernel debugger

Download all attachments as: .zip

Change History (14)

comment:1 by mmlr, 11 years ago

Please at least try to use the search function. Using "nmi" as keyword you'd for example find #3113, #2680 and indirectly #2243. Can you check if removing the firewire busmanager resolves the issue or try other things potentially mentioned in the other reports? Other than that please provide infos. A revision number, a backtrace, syslog output, hardware description, what you have tried already...

comment:2 by Adek336, 11 years ago

Sorry!

comment:3 by Adek336, 11 years ago

Disabling fw_raw doesn't help. I'm seeing backtraces like

http://dev.haiku-os.org/attachment/ticket/2680/backtrace.JPG

Enabling on screen debug results in 100% reproducible NMI at the very beginning of the boot, after a few messages appear on the screen, after things like the first "PCI: dom 0, bus 0, dev 1"-type message. The message the NMI occurs after varies between boots.

I also have NMIs which occur in picasso and net_server.

by Adek336, 11 years ago

Attachment: img_1027.jpg added

NMI during the handling of a panic in thread picasso

by Adek336, 11 years ago

Attachment: img_1028.jpg added

NMI in draw_cursor_ _F11

by Adek336, 11 years ago

Attachment: img_1031.jpg added

NMI panic during the handling of another panic in thread net_server

comment:4 by Adek336, 11 years ago

img_1028.jpg shows NMI in draw_cursor_ _F11, right after booting with on screen debug enabled. I also get KDLs in draw_cursor_ _F11 with on screen debug disabled, occuring when I, for example, press F12 and the blue screen prompt tries to show the text cursor. Can continue through.

Sometimes when I press F12 I get the panic message but not "Welcome to kernel debugging land" and everything is the freeze. Cannot cont through.

img_1027.jpg, img_1031.jpg: note that the panic handler itself invoked a panic. Can cont through.

I also get (probably NMIs) right between the last boot icon and showing of the Desktop - that is, with a blank screen. Can continue through.

hrev28643

comment:5 by Adek336, 11 years ago

Also note symptoms I described in ticked #1150.

by Adek336, 11 years ago

Attachment: img_1043.jpg added

Failure to show KDL prompt: possibly due to NMI in the kernel debugger

comment:6 by scottmc, 8 years ago

Can you recheck this with a recent Haiku build? It may have been fixed recently.

comment:7 by scottmc, 8 years ago

Blocking: 7665 added

comment:8 by diver, 7 years ago

Component: - GeneralSystem/Kernel

comment:9 by tqh, 5 years ago

Resolution: invalid
Status: newclosed

No feedback in three years, closing.

comment:10 by waddlesplash, 16 months ago

Blocking: 7665 removed
Note: See TracTickets for help on using tickets.