Opened 10 years ago

Closed 7 years ago

Last modified 7 years ago

#3249 closed bug (fixed)

Jukebox can't run on GCC4/GCC2 hibryd build

Reported by: miqlas Owned by: axeld
Priority: normal Milestone: R1
Component: Kits/Media Kit Version: R1/Development
Keywords: Cc: mdisreali@…
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

I try to run the latest (0.4) Jukebox version on an hrev28832 version, but i get error massage:

~> /Haiku1/apps/Jukebox
resolve symbol "_ZNK11BArchivable7ArchiveEP8BMessageb" returned: -2147478780
resolve symbol "_ZNK5BView7ArchiveEP8BMessageb" returned: -2147478780
resolve symbol "_ZNK12BApplication7ArchiveEP8BMessageb" returned: -2147478780
resolve symbol "_ZNK5BView7ArchiveEP8BMessageb" returned: -2147478780
resolve symbol "_ZNK5BView7ArchiveEP8BMessageb" returned: -2147478780
resolve symbol "_ZNK11BArchivable7ArchiveEP8BMessageb" returned: -2147478780
resolve symbol "_ZNK11BArchivable7ArchiveEP8BMessageb" returned: -2147478780
resolve symbol "_ZNK7BWindow7ArchiveEP8BMessageb" returned: -2147478780
resolve symbol "_ZNK11BArchivable7ArchiveEP8BMessageb" returned: -2147478780
resolve symbol "_ZNK11BArchivable7ArchiveEP8BMessageb" returned: -2147478780
resolve symbol "_ZTVN10__cxxabiv117__class_type_infoE" returned: -2147478780
resolve symbol "_ZNK11BArchivable7ArchiveEP8BMessageb" returned: -2147478780
resolve symbol "_ZNK11BArchivable7ArchiveEP8BMessageb" returned: -2147478780
resolve symbol "_ZNK11BArchivable7ArchiveEP8BMessageb" returned: -2147478780
resolve symbol "_ZN5BList14_ReservedList1Ev" returned: -2147478780
Kill Thread

Attachments (2)

BePDF_GCC4.jpg (303.8 KB) - added by miqlas 10 years ago.
BePDF error massage
hrev44378-2h_jukebox_crash_on_launch.txt (7.2 KB) - added by Disreali 7 years ago.

Download all attachments as: .zip

Change History (15)

comment:1 Changed 10 years ago by anevilyak

It looks like you probably grabbed the Zeta version instead of R5. At least http://www.bebits.com/bob/22022/Jukebox_V04_R5.zip works correctly on gcc2/4 hybrid build here.

comment:2 Changed 10 years ago by miqlas

No, i have R5 version, i'm sure, because i use the binary from my Haiku GCC2 build partition, and i always use it for audio :)

I get these error with BePDF, and with ProjectConceptor too.

Jukebox: In gdb:

(gdb) bt
#0  0x00661450 in BBitmap::Bounds () from /boot/beos/system/lib/gcc2/libbe.so
#1  0x0025a5d1 in PlayButton::setSkin ()
#2  0x00244f7b in Jukebox::initViews ()
#3  0x00243c90 in Jukebox::Jukebox ()
#4  0x0024e30f in main ()
(gdb) 

BePDF: Shoot: http://boly.hu/~miqlas/haiku/BePDF_GCC4.jpg

In gdb:

(gdb) bt
#0  0xffff0104 in ?? ()
#1  0x007b93e6 in port_buffer_size_etc ()
   from /boot/beos/system/lib/gcc2/libroot.so
#2  0x00571b92 in BLooper::ReadRawFromPort ()
   from /boot/beos/system/lib/gcc2/libbe.so
#3  0x00571c1e in BLooper::ReadMessageFromPort ()
   from /boot/beos/system/lib/gcc2/libbe.so
#4  0x005712bb in BLooper::MessageFromPort ()
   from /boot/beos/system/lib/gcc2/libbe.so
#5  0x00571dab in BLooper::task_looper ()
   from /boot/beos/system/lib/gcc2/libbe.so
#6  0x0056563d in BApplication::Run () from /boot/beos/system/lib/gcc2/libbe.so
#7  0x002da854 in main ()
(gdb)

ProjectConceptor:

In Terminal:

resolve symbol "_ZNK11BArchivable7ArchiveEP8BMessageb" returned: -2147478780
resolve symbol "_ZNK5BView7ArchiveEP8BMessageb" returned: -2147478780
resolve symbol "_ZNK12BApplication7ArchiveEP8BMessageb" returned: -2147478780
resolve symbol "_ZNK5BView7ArchiveEP8BMessageb" returned: -2147478780
resolve symbol "_ZNK5BView7ArchiveEP8BMessageb" returned: -2147478780
resolve symbol "_ZNK11BArchivable7ArchiveEP8BMessageb" returned: -2147478780
resolve symbol "_ZNK11BArchivable7ArchiveEP8BMessageb" returned: -2147478780
resolve symbol "_ZNK7BWindow7ArchiveEP8BMessageb" returned: -2147478780
resolve symbol "_ZNK11BArchivable7ArchiveEP8BMessageb" returned: -2147478780
resolve symbol "_ZNK11BArchivable7ArchiveEP8BMessageb" returned: -2147478780
resolve symbol "_ZTVN10__cxxabiv117__class_type_infoE" returned: -2147478780
resolve symbol "_ZNK11BArchivable7ArchiveEP8BMessageb" returned: -2147478780
resolve symbol "_ZNK11BArchivable7ArchiveEP8BMessageb" returned: -2147478780
resolve symbol "_ZNK11BArchivable7ArchiveEP8BMessageb" returned: -2147478780
resolve symbol "_ZN5BList14_ReservedList1Ev" returned: -2147478780

In gdb:

0x0093beda in GraphEditor::AttachedToWindow (this=0x18046260)
    at GraphEditor.cpp:574
574     GraphEditor.cpp: No such file or directory.
        in GraphEditor.cpp
(gdb) bt
#0  0x0093beda in GraphEditor::AttachedToWindow (this=0x18046260)
    at GraphEditor.cpp:574
#1  0x003fe848 in BView::_Attach () from /boot/beos/system/lib/gcc2/libbe.so
#2  0x003fe8c3 in BView::_Attach () from /boot/beos/system/lib/gcc2/libbe.so
#3  0x003fb78d in BView::_AddChild () from /boot/beos/system/lib/gcc2/libbe.so
#4  0x003fb629 in BView::AddChild () from /boot/beos/system/lib/gcc2/libbe.so
#5  0x003de82e in BTab::Select () from /boot/beos/system/lib/gcc2/libbe.so
#6  0x003e047c in BTabView::Select () from /boot/beos/system/lib/gcc2/libbe.so
#7  0x0023c2d4 in MainView::Select (this=0x18019fe0, tab=0x18063ab0)
    at MainView.cpp:53
#8  0x00258da5 in PWindow::AddEditor (this=0x1802c1a8, 
    name=0x943e02 "GraphEditor", editor=0x18046260) at Document/PWindow.cpp:465
#9  0x00253203 in PWindow::CreatEditorList (this=0x1802c1a8)
    at Document/PWindow.cpp:87
#10 0x0025a658 in PWindow::Show (this=0x1802c1a8) at Document/PWindow.cpp:875
#11 0x00252af1 in PWindow::PWindow (this=0x1802c1a8, rect=
      {left = 50, top = 50, right = 973, bottom = 717}, document=0x1801a108)
    at Document/PWindow.cpp:35
#12 0x0024bffc in PDocument::Init (this=0x1801a108)
    at Document/PDocument.cpp:261
#13 0x0024a834 in PDocument::PDocument (this=0x1801a108, 
    initManager=0x180202a0) at Document/PDocument.cpp:31
#14 0x002511f2 in PDocumentManager::CreateDocument (this=0x180202a0)
    at Document/PDocumentManager.cpp:123
---Type <return> to continue, or q <return> to quit---
#15 0x002505cf in PDocumentManager::PDocumentManager (this=0x180202a0)
    at Document/PDocumentManager.cpp:9
#16 0x0023c551 in ProjektConceptor::ProjektConceptor (this=0x1801a230)
    at ProjectConceptor.cpp:144
#17 0x0023d2ce in main () at ProjectConceptor.cpp:298
(gdb) 

Changed 10 years ago by miqlas

Attachment: BePDF_GCC4.jpg added

BePDF error massage

comment:3 Changed 10 years ago by mt

It seems that BePDF fails in gcc4/gcc2 hybrid system because of /boot/beos/system/lib/gcc2/libtranslation.so 's problem. I think gcc2/libtranslation.so try to load gcc4 version of Translator add-ons instead of gcc2's .
syslogs:

KERN: runtime_loader: elf_resolve_symbol: could not resolve symbol '_ZNK11BArchivable7ArchiveEP8BMessageb'
KERN: runtime_loader: troubles relocating: 0x80001304 (image: /boot/beos/system/add-ons/Translators/BMPTranslator, BMPTranslator)
KERN: runtime_loader: elf_resolve_symbol: could not resolve symbol '_ZNK5BView7ArchiveEP8BMessageb'
KERN: runtime_loader: troubles relocating: 0x80001304 (image: /boot/beos/system/add-ons/Translators/EXRTranslator, EXRTranslator)
KERN: runtime_loader: elf_resolve_symbol: could not resolve symbol '_ZNK12BApplication7ArchiveEP8BMessageb'
KERN: runtime_loader: troubles relocating: 0x80001304 (image: /boot/beos/system/add-ons/Translators/GIFTranslator, GIFTranslator)
KERN: runtime_loader: elf_resolve_symbol: could not resolve symbol '_ZNK5BView7ArchiveEP8BMessageb'
KERN: runtime_loader: troubles relocating: 0x80001304 (image: /boot/beos/system/add-ons/Translators/JPEG2000Translator, JPEG2000Translator)
KERN: runtime_loader: elf_resolve_symbol: could not resolve symbol '_ZNK5BView7ArchiveEP8BMessageb'
KERN: runtime_loader: troubles relocating: 0x80001304 (image: /boot/beos/system/add-ons/Translators/JPEGTranslator, JPEGTranslator)
KERN: runtime_loader: elf_resolve_symbol: could not resolve symbol '_ZNK11BArchivable7ArchiveEP8BMessageb'
KERN: runtime_loader: troubles relocating: 0x80001304 (image: /boot/beos/system/add-ons/Translators/PCXTranslator, PCXTranslator)
KERN: runtime_loader: elf_resolve_symbol: could not resolve symbol '_ZNK11BArchivable7ArchiveEP8BMessageb'
KERN: runtime_loader: troubles relocating: 0x80001304 (image: /boot/beos/system/add-ons/Translators/PNGTranslator, PNGTranslator)
KERN: runtime_loader: elf_resolve_symbol: could not resolve symbol '_ZNK7BWindow7ArchiveEP8BMessageb'
KERN: runtime_loader: troubles relocating: 0x80001304 (image: /boot/beos/system/add-ons/Translators/PPMTranslator, PPMTranslator)
KERN: runtime_loader: elf_resolve_symbol: could not resolve symbol '_ZNK11BArchivable7ArchiveEP8BMessageb'
KERN: runtime_loader: troubles relocating: 0x80001304 (image: /boot/beos/system/add-ons/Translators/RAWTranslator, RAWTranslator)
KERN: runtime_loader: elf_resolve_symbol: could not resolve symbol '_ZNK11BArchivable7ArchiveEP8BMessageb'
KERN: runtime_loader: troubles relocating: 0x80001304 (image: /boot/beos/system/add-ons/Translators/RTF-Translator, RTF-Translator)
KERN: runtime_loader: elf_resolve_symbol: could not resolve symbol '_ZTVN10__cxxabiv117__class_type_infoE'
KERN: runtime_loader: troubles relocating: 0x80001304 (image: /boot/beos/system/add-ons/Translators/SGITranslator, SGITranslator)
KERN: runtime_loader: elf_resolve_symbol: could not resolve symbol '_ZNK11BArchivable7ArchiveEP8BMessageb'
KERN: runtime_loader: troubles relocating: 0x80001304 (image: /boot/beos/system/add-ons/Translators/STXTTranslator, STXTTranslator)
KERN: runtime_loader: elf_resolve_symbol: could not resolve symbol '_ZNK11BArchivable7ArchiveEP8BMessageb'
KERN: runtime_loader: troubles relocating: 0x80001304 (image: /boot/beos/system/add-ons/Translators/TGATranslator, TGATranslator)
KERN: runtime_loader: elf_resolve_symbol: could not resolve symbol '_ZNK11BArchivable7ArchiveEP8BMessageb'
KERN: runtime_loader: troubles relocating: 0x80001304 (image: /boot/beos/system/add-ons/Translators/TIFFTranslator, TIFFTranslator)
KERN: runtime_loader: elf_resolve_symbol: could not resolve symbol '_ZN5BList14_ReservedList1Ev'
KERN: runtime_loader: troubles relocating: 0x80001304 (image: /boot/beos/system/add-ons/Translators/WonderBrushTranslator, WonderBrushTranslator)
KERN: 246: DEBUGGER: Need to set the 'disabled' pictures for this BPictureButton 
KERN: debug_server: Thread 246 entered the debugger: Debugger call: `Need to set the 'disabled' pictures for this BPictureButton '
KERN: stack trace, current PC 0xffff0102  :
KERN:   (0x78184c4c)  0x5da3aa  Draw__14BPictureButtonG5BRect + 0x7a
KERN:   (0x78184c8c)  0x28d5b0  Draw__12BitmapButtonG5BRect + 0x7c
KERN:   (0x78184cfc)  0x625ed8  _Draw__5BViewG5BRect + 0x94
KERN:   (0x78184d3c)  0x62a7c9  DispatchMessage__7BWindowP8BMessageP8BHandler + 0x1469
KERN:   (0x78184f1c)  0x62e438  task_looper__7BWindow + 0x270
KERN:   (0x78184f7c)  0x5734cb  _task0___7BLooperPv + 0x3f
KERN:   (0x78184fac)  0x7c6b98  thread_entry + 0x20
KERN: debug_server: Killing team 232 (/boot/apps/BePDF/BePDF)
KERN: debug_server: TeamDebugHandler::Init(): Failed to get info for team 232: Operation on invalid team
KERN: debug_server: KillTeam(): Error getting info for team 232: Operation on invalid team
KERN: debug_server: Killing team 232 ()

comment:4 Changed 9 years ago by miqlas

I checked it in hrev35081 gcc2h:

KERN: runtime_loader: /boot/var/tmp/Jukebox: Could not resolve symbol 'Notify__12BSoundPlayerQ212BSoundPlayer25sound_player_notificatione'
KERN: runtime_loader: /boot/var/tmp/Jukebox: Troubles relocating: Symbol not found
KERN: runtime_loader: /boot/var/tmp/Jukebox: Could not resolve symbol 'Notify__12BSoundPlayerQ212BSoundPlayer25sound_player_notificatione'
KERN: runtime_loader: /boot/var/tmp/Jukebox: Troubles relocating: Symbol not found
KERN: runtime_loader: /boot/var/tmp/Jukebox: Could not resolve symbol 'Notify__12BSoundPlayerQ212BSoundPlayer25sound_player_notificatione'
KERN: runtime_loader: /boot/var/tmp/Jukebox: Troubles relocating: Symbol not found

comment:5 Changed 9 years ago by Disreali

Cc: mdisreali@… added
Version: R1/pre-alpha1R1/Development

Tested on hrev36131 gcc2only and still getting error.

/Haiku_Data> Jukebox
runtime_loader: /Haiku_Data/Jukebox: Could not resolve symbol 'Notify__12BSoundPlayerQ212BSoundPlayer25sound_player_notificatione'
resolve symbol "Notify__12BSoundPlayerQ212BSoundPlayer25sound_player_notificatione" returned: -2147478780
runtime_loader: /Haiku_Data/Jukebox: Troubles relocating: Symbol not found

I know that Jukebox worked on the Senryu releases. Not sure upon which rev they were based.

comment:6 Changed 9 years ago by Disreali

The last rev the I have found on which Jukebox still works is hrev34464. I now need to learn how to jam Haiku and test between that and hrev34514.

comment:7 Changed 9 years ago by axeld

Component: ApplicationsKits/Media Kit
Status: newassigned

This is a binary compatibility problem I introduced in hrev34474.

comment:8 Changed 9 years ago by anevilyak

The missing symbol is a private one though, isn't it? At least AFAICT ::Notify() isn't part of the published BSoundPlayer API.

comment:9 Changed 9 years ago by axeld

Status: assignedin-progress

comment:10 Changed 9 years ago by axeld

Resolution: fixed
Status: in-progressclosed

Fixed in hrev36212.

It's private, but the problem is that it is virtual, and therefore one cannot change its name without breaking compatibility. They shouldn't be virtual at all, anyway, but it's too late for that for GCC2.

comment:11 Changed 7 years ago by Disreali

Resolution: fixed
Status: closedreopened

Jukebox is once crashes on hrev44378-2h.

attaching backtrace.

Changed 7 years ago by Disreali

comment:12 Changed 7 years ago by diver

Resolution: fixed
Status: reopenedclosed

I assume this is because of #7785. Please open a new ticket if not.

comment:13 in reply to:  12 Changed 7 years ago by Disreali

Diver, you where correct. I forgot about that issue.

Sorry for the noise.

Note: See TracTickets for help on using tickets.