Opened 10 years ago

Closed 10 years ago

#3297 closed bug (fixed)

PackageInstaller fails to open/install some packages

Reported by: rossi Owned by: sil2100
Priority: normal Milestone: R1
Component: Applications/PackageInstaller Version: R1/pre-alpha1
Keywords: Cc: adek336@…
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

PackageInstaller fails to open/install the QEMU package from beBits (http://www.bebits.com/app/4208).

Error: "I was unable to read the given package file."

Happens on hrev28892.

Screenshot of error message attached.

Attachments (2)

screenshot1 (11.4 KB) - added by rossi 10 years ago.
PackageInstaller_QEMU.log (16.4 KB) - added by aldeck 10 years ago.

Download all attachments as: .zip

Change History (19)

Changed 10 years ago by rossi

Attachment: screenshot1 added

comment:1 Changed 10 years ago by Adek336

Cc: adek336@… added

comment:2 Changed 10 years ago by anevilyak

Component: ApplicationsApplications/PackageInstaller
Owner: changed from axeld to sil2100

comment:3 Changed 10 years ago by aldeck

I can confirm, it happened to me a month ago, forgot to report.

comment:4 Changed 10 years ago by mmlr

For the meantime the zipped version can be used: http://haiku.mlotz.ch/qemu-0.9.1.zip

comment:5 Changed 10 years ago by Adek336

Thank you, the .zip file works fine!

comment:6 Changed 10 years ago by aldeck

Attached the output produced with #define DEBUG_PARSER.

The PackageInfo::Parse method fails and returns on line 1061 in PackageInfo.cpp

didn't look further, HTH

Changed 10 years ago by aldeck

Attachment: PackageInstaller_QEMU.log added

comment:7 Changed 10 years ago by sil2100

Thanks for the debugging info! I will look into this problem in more detail as soon as possible - it might take some time, though, since I have a rough week right now.

comment:8 Changed 10 years ago by aldeck

Summary: PackageInstaller fails to open/install the QEMU package from beBitsPackageInstaller fails to open/install some packages

Same problem with http://revolf.free.fr/beos/apps/XEmacs-21.4.9-x86-bin.pkg reported by Blub\0 on #haiku

comment:9 Changed 10 years ago by korli

XEmacs-21.4.9-x86-bin.pkg installs correctly here: though there is a warning with an invalid size.

comment:10 Changed 10 years ago by sil2100

Resolution: fixed
Status: newclosed

This bug has been fixed by Jérôme around hrev29216. Thanks korli!

comment:11 Changed 10 years ago by axeld

Resolution: fixed
Status: closedreopened

No, this actually hasn't been fixed, it's still reproducible with the Qemu package in hrev29876.

comment:12 Changed 10 years ago by sil2100

This is strange, since I cannot reproduce it here. I tried both qemu packages (BONE and net_server) and they both open and install without problems (hrev29880). Does it happen during every package installation try? Does it fail to open or install the package? What qemu package is the one having problems?

Thanks in advice.

comment:13 Changed 10 years ago by mmadia

is BEOS:APP_SIG listed as an index on the partitions? would that affect this?

comment:14 Changed 10 years ago by anevilyak

Completely unrelated to APP_SIG, this has to do with parsing the pkg itself.

comment:15 Changed 10 years ago by axeld

The problem appears with Qemu 0.9.1 on BeBits. It starts to install (even copies a few files), and then tells me the installation was aborted.

comment:16 in reply to:  15 Changed 10 years ago by korli

Replying to axeld:

The problem appears with Qemu 0.9.1 on BeBits. It starts to install (even copies a few files), and then tells me the installation was aborted.

Did you check there is enough space left ? Package install was failing because of this last time I tried.

comment:17 Changed 10 years ago by axeld

Resolution: fixed
Status: reopenedclosed

Okay, this actually seems to be a different bug. I had a failed install of Qemu on this partition, and PackageInstaller could not handle this. I'll open a new ticket for it.

Note: See TracTickets for help on using tickets.