Opened 10 years ago

Closed 11 months ago

#3305 closed bug (fixed)

page fault in find_root_device

Reported by: Adek336 Owned by: axeld
Priority: normal Milestone: R1
Component: Drivers/Network Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking: #6294
Has a Patch: no Platform: All

Description

hrev28910, real hardware, 3c900b-combo etherlink xl[cyclone] 10b7/9005, page fault in net_server during bootup, happened only once in many boots.

find_root_device
if_initname
xl_attach
device_attach

Attachments (2)

img_1782.jpg (256.4 KB) - added by Adek336 10 years ago.
img_1791.jpg (102.6 KB) - added by Adek336 10 years ago.

Download all attachments as: .zip

Change History (7)

Changed 10 years ago by Adek336

Attachment: img_1782.jpg added

Changed 10 years ago by Adek336

Attachment: img_1791.jpg added

comment:1 Changed 10 years ago by Adek336

That time I believe I had my onboard via rhine lan disabled in BIOS. Now due to some failure it got enabled. First of all Haiku didn't show the 3com adapter in the network preflet and the vr adapter was set to some strange static config and when changed to DHCP, after closing and opening the network preflet again the static config would reappear. Secondly, the KDL came again, but this time with vr instead of xl and vr instead of 3com in the text.

comment:2 Changed 10 years ago by Adek336

comment:3 Changed 9 years ago by axeld

Blocking: 6294 added

(In #6294) Please attach images to the bug instead of linking it in the future.

In any case, the bug description has little to do with the KDL. The bug that is seen in the KDL is just a duplicate of #3305.

comment:4 Changed 7 years ago by mmlr

Probably fixed in hrev43393. The issue only happened very rarely on my system so I can't positively say that it is fixed, but the stale list entry would explain the problem (it only doesn't really explain why it didn't always crash).

comment:5 Changed 11 months ago by waddlesplash

Resolution: fixed
Status: newclosed

No reply in 7 years, assuming indeed fixed.

Note: See TracTickets for help on using tickets.