Opened 9 years ago

Closed 9 years ago

#6294 closed bug (duplicate)

PANIC: vm_page_fault: unhandled page fault with net_server and mobile connect

Reported by: Karvjorm Owned by: mmlr
Priority: normal Milestone: R1
Component: Drivers/USB Version: R1/alpha2
Keywords: vm_page_fault HUAWEI HSDPA USB Stick net_server Cc: Karvjorm
Blocked By: #3305 Blocking:
Has a Patch: no Platform: All

Description

I booted hrev37437 (gcc4) VMware environment and it crashed soon after showing the desktop environment. Reason is HUAWEI Mobile Connect (Model: E160E HSDPA USB Stick) that I had attached to a USB port, I suppose.

I have a working Cable Internet connection (via Ethernet connection) and this HUAWEI Mobile Connect was not working, because I can't enter pin code for the stick. I wanted only test how Haiku can handle this kind of stick.

This stick includes two USB interfaces, I suppose. The other one is USB Disk and I can mount it onto Desktop. But the other interface is USB modem interface and I should need some special manipulation plus pin code to get it to work.

But reading debug text in picture it looks like the Haiku kernel tried to create some driver, but failed.

Here is a part of syslog (but I'm not sure if this is the same time when crash occured or some other booting):

KERN: slab memory manager: created area 0xa0000000 (5315)
KERN: usb hub 2: port 0: new device connected
KERN: usb hub 2: port 1: new device connected
KERN: usb_disk: device reports a lun count of 1
KERN: usb_disk: vendor_identification    "HUAWEI  "
KERN: usb_disk: product_identification   "Mass Storage    "
KERN: usb_disk: product_revision_level   "2.31"
KERN: usb_disk: request_sense: media changed
KERN: Media changed from /dev/disk/usb/0/0/raw
KERN: KDiskDeviceManager::_ScanPartition(/dev/disk/usb/0/0/raw)
KERN: intel: ep_std_ops(0x1)
KERN:   trying: partitioning_systems/intel/extended/v1
KERN:   returned: -1
KERN: intel: ep_std_ops(0x2)
KERN: intel: pm_std_ops(0x1)
KERN:   trying: partitioning_systems/intel/map/v1
KERN: intel: pm_identify_partition(8, 2: 0, 84541440, 2048)
KERN:   returned: -1
KERN: intel: pm_std_ops(0x2)
KERN:   trying: file_systems/bfs/v1
KERN:   returned: -1
KERN:   trying: file_systems/devfs/v1
KERN:   returned: -1
KERN:   trying: file_systems/rootfs/v1
KERN:   returned: -1
KERN:   trying: partitioning_systems/amiga_rdb/v1
KERN:   returned: -1
KERN:   trying: partitioning_systems/apple/v1
KERN:   returned: 0.5
KERN:   trying: partitioning_systems/efi_gpt/v1
KERN:   returned: -1
KERN:   trying: partitioning_systems/session/v1
KERN: usb_disk: unhandled ioctl 10102
Last message repeated 1 time
KERN:   returned: -1
KERN:   trying: file_systems/attribute_overlay/v1
KERN:   returned: -1
KERN:   trying: file_systems/cdda/v1
KERN: usb_disk: unhandled ioctl 10102
KERN:   returned: -1
KERN:   trying: file_systems/ext2/v1
KERN:   returned: -1
KERN:   trying: file_systems/fat/v1
KERN:   returned: -1
KERN: googlefs: std_ops(INIT)
KERN:   trying: file_systems/googlefs/v1
KERN:   returned: -1
KERN: googlefs: std_ops(UNINIT)
KERN:   trying: file_systems/iso9660/v1
KERN: identify(8, 0x9f9566a0)
KERN: found primary descriptor
KERN:   iso9660_primary_descriptor:
KERN:     volume descriptor type: 1 (primary)
KERN:     standard identifier:    CD001 (valid)
KERN:     version:                1
KERN:     identifier:             'MOBIILILAAJAKAISTA              '
KERN:     size:                   10595
KERN:     set size:               1
KERN:     sequence number:        1
KERN:     logical block size:     2048
KERN:     path table size:        72
KERN:     set identifier:         NOT_SET                     
KERN:     root directory record:
KERN:       length:               34
KERN:       location:             21
KERN:       data length:          2048
KERN:       volume space:         1
KERN: iso9660_info::set_string(0x9f9566a0 ('<NULL>'), 'MOBIILILAAJAKAISTA              ', 18)
KERN:   returned: 0.6
KERN:   trying: file_systems/nfs/v1
KERN:   returned: -1
KERN:   trying: file_systems/ntfs/v1
KERN:   returned: -1
KERN:   trying: file_systems/reiserfs/v1
KERN:   returned: -1
KERN:   trying: file_systems/udf/v1
KERN: udf_recognize: Invalid sequence. status = -1
KERN:   returned: -1
KERN:   trying: file_systems/write_overlay/v1
KERN:   returned: -1
KERN:   scanning with: file_systems/iso9660/v1
KERN: ps2: strange mouse data, y-delta 253, trying resync
KERN: ps2: bad mouse data, trying resync
KERN: ps2: strange mouse data, x-delta -125, trying resync
KERN: ps2: bad mouse data, trying resync

Change History (2)

comment:2 Changed 9 years ago by axeld

Blocked By: 3305 added
Resolution: duplicate
Status: newclosed

Please attach images to the bug instead of linking it in the future.

In any case, the bug description has little to do with the KDL. The bug that is seen in the KDL is just a duplicate of #3305.

Note: See TracTickets for help on using tickets.