Opened 10 years ago

Closed 10 years ago

#3370 closed bug (fixed)

Building gcc4 cross tools fails on Ubuntu 8.10

Reported by: rossi Owned by: mmlr
Priority: normal Milestone: R1
Component: Build System Version: R1/pre-alpha1
Keywords: Cc: umccullough@…, julius.bullinger+haiku@…
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I've tried to build the new cross compiler on my primary build box (Ubuntu 8.10) this morning. However the build failed due to missing ./get_patches.sh. Here is the relevant snippet from the build output:

rossi@skullcap:~/develop/haiku/haiku/generated.gcc4$ ../configure --build-cross-tools-gcc4 x86 ../../buildtools/ --include-gpl-addons --include-3rdparty --enable-multiuser --use-gcc-pipe

[...]

./get_patches.sh > get_patches.c
rm -f get_patches.c

/bin/bash: ./get_patches.sh: No such file or directory if /bin/bash ./libtool --tag=CC --mode=compile gcc -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DTIME_WITH_SYS_TIME=1 -DHAVE_STDARG=1 -DHAVE_SYS_TIME_H=1 -DHAVE_SETLOCALE=1 -DHAVE_GETTIMEOFDAY=1 -DMPFR_HAVE_FESETROUND=1 -DHAVE_FLOOR=1 -DHAVE_CEIL=1 -DHAVE_LDOUBLE_IEEE_EXT_LITTLE=1 -DHAVE_ATTRIBUTE_MODE=1 -DHAVE_ALLOCA_H=1 -I. -I/home/rossi/develop/haiku/buildtools/gcc/mpfr -I/home/rossi/develop/haiku/haiku/generated.gcc4/cross-tools-build/gcc/./gmp -I/home/rossi/develop/haiku/haiku/generated.gcc4/cross-tools-build/gcc/./gmp/tune

-O2 -MT get_patches.lo -MD -MP -MF ".deps/get_patches.Tpo" -c -o

get_patches.lo get_patches.c; \

then mv -f ".deps/get_patches.Tpo" ".deps/get_patches.Plo"; else

rm -f ".deps/get_patches.Tpo"; exit 1; fi

gcc -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DTIME_WITH_SYS_TIME=1

-DHAVE_STDARG=1 -DHAVE_SYS_TIME_H=1 -DHAVE_SETLOCALE=1 -DHAVE_GETTIMEOFDAY=1 -DMPFR_HAVE_FESETROUND=1 -DHAVE_FLOOR=1 -DHAVE_CEIL=1 -DHAVE_LDOUBLE_IEEE_EXT_LITTLE=1 -DHAVE_ATTRIBUTE_MODE=1 -DHAVE_ALLOCA_H=1 -I. -I/home/rossi/develop/haiku/buildtools/gcc/mpfr -I/home/rossi/develop/haiku/haiku/generated.gcc4/cross-tools-build/gcc/./gmp -I/home/rossi/develop/haiku/haiku/generated.gcc4/cross-tools-build/gcc/./gmp/tune -O2 -MT get_patches.lo -MD -MP -MF .deps/get_patches.Tpo -c get_patches.c -o get_patches.o gcc: get_patches.c: No such file or directory gcc: no input files make[3]: * [get_patches.lo] Error 1 make[3]: Leaving directory `/home/rossi/develop/haiku/haiku/generated.gcc4/cross-tools-build/gcc/mpfr' make[2]: * [all-recursive] Error 1 make[2]: Leaving directory `/home/rossi/develop/haiku/haiku/generated.gcc4/cross-tools-build/gcc/mpfr' make[1]: * [all-mpfr] Error 2 make[1]: Leaving directory `/home/rossi/develop/haiku/haiku/generated.gcc4/cross-tools-build/gcc' make: * [all] Error 2 ERROR: Building gcc failed. rossi@skullcap:~/develop/haiku/haiku/generated.gcc4$

Both trees (buildtools and haiku itself) have been on hrev29046.

Change History (11)

comment:1 Changed 10 years ago by bonefish

Owner: changed from bonefish to mmlr

comment:2 Changed 10 years ago by mmlr

Yes I know. It's not completed. Sadly I was interrupted by work ;-). Will try to finish up tonight.

comment:3 Changed 10 years ago by mmlr

Please try again with hrev29059 of the buildtools. Also note that you need to update build/scripts under the haiku trunk to current as well as the buildtool preparation has changed a bit.

comment:4 Changed 10 years ago by umccullough

gcc4 cross-tools compile for me now on a debian machine (and probably also on ubuntu 8.10 as I had the same failure on both - but not the one mentioned here)

However, it does not compile Haiku successfully - I'll open a separate ticket.

comment:5 Changed 10 years ago by rossi

Tried with hrev29059, same failure as before. I'll try on another machine later tonight in order to make sure its not the specific Ubuntu install.

comment:6 Changed 10 years ago by umccullough

I apologize for any confusion I may have created here - it just came to my attention last night that the ubuntu box I had successfully built the cross-tools on was still 8.04. Apparently it was my laptop only that i had updated to 8.10.

Updating it now, will re-test.

comment:7 Changed 10 years ago by umccullough

Cc: umccullough@… added

comment:8 Changed 10 years ago by umccullough

After updating my ubuntu 8.04 box to 8.10, and also grabbing the latest sources, it does seem to work for me:

make[1]: Leaving directory `/home/umccullough/haiku/haiku/trunk4/generated/cross-tools-build/gcc'
binutils and gcc for cross compilation have been built successfully!
umccullough@c2xubu:~/haiku/haiku/trunk4$ uname -a
Linux c2xubu 2.6.27-11-generic #1 SMP Thu Jan 22 17:22:40 UTC 2009 i686 GNU/Linux
umccullough@c2xubu:~/haiku/haiku/trunk4$ cat /proc/version
Linux version 2.6.27-11-generic (buildd@rothera) (gcc version 4.3.2 (Ubuntu 4.3.2-1ubuntu11) ) #1 SMP Thu Jan 22 17:22:40 UTC 2009
umccullough@c2xubu:~/haiku/haiku/trunk4$ 

comment:9 Changed 10 years ago by kwurzel

Cc: julius.bullinger+haiku@… added

I'm using Arch Linux with 2.6.28 and the latest GCC 4.3.3, but the problem still persists in hrev29072!

comment:10 in reply to:  9 Changed 10 years ago by mmlr

Replying to kwurzel:

I'm using Arch Linux with 2.6.28 and the latest GCC 4.3.3, but the problem still persists in hrev29072!

Which problem exactly is that? The one reported here with the "get_patches" issue? There were other issues with missing includes but they should be fixed.

comment:11 Changed 10 years ago by mmlr

Resolution: fixed
Status: newclosed

This problem here should be fixed now so cross-tools building should work. After cross-tools creation you will likely hit #3375 though.

Note: See TracTickets for help on using tickets.