Opened 10 years ago

Closed 10 years ago

#3379 closed bug (fixed)

app_server crash / issues with font cache

Reported by: rossi Owned by: stippi
Priority: normal Milestone: R1
Component: Servers/app_server Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Apperently since hrev29047 (change in FontServerCache), I do experience a lot of crashes in app_server with a trip to GDB.

GDB backtrace attached.

Originally I thought this was related to ticket #3282, however it is a seperate issue, therefore this new ticket.

Comment by anevilyak (taken from ticket #3282):

"The backtrace you submitted looks to have been caused by hrev29047. This is a completely different bug and probably should have a separate ticket filed, as it seems to be trying to delete either already freed or uninitialized font cache pointer, which is a separate issue from the originally reported crash in this ticket."

Attachments (1)

app_server_crash3.jpg (302.9 KB) - added by rossi 10 years ago.

Download all attachments as: .zip

Change History (3)

Changed 10 years ago by rossi

Attachment: app_server_crash3.jpg added

comment:1 Changed 10 years ago by anevilyak

Owner: changed from axeld to stippi

comment:2 Changed 10 years ago by stippi

Resolution: fixed
Status: newclosed

Fixed in hrev29061. The memory was already managed by the block allocator. Sorry about the inconvenience.

Note: See TracTickets for help on using tickets.