Opened 11 years ago

Closed 11 years ago

#3431 closed bug (duplicate)

haiku hangs when plugin a usb stick

Reported by: clemens Owned by: mmlr
Priority: normal Milestone: R1
Component: Drivers/USB Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: #2084 Blocking:
Has a Patch: no Platform: All

Description

haiku hangs when plugin a usb stick. No kdl no keyboard input (f12) after plugin the stick. The problem was introduced in 26491. Attached is a syslog of a normal boot.

Attachments (1)

syslog (74.5 KB ) - added by clemens 11 years ago.
syslog

Download all attachments as: .zip

Change History (6)

by clemens, 11 years ago

Attachment: syslog added

syslog

comment:1 by anevilyak, 11 years ago

Component: System/KernelDrivers/USB
Owner: changed from axeld to mmlr

Could you please try that with a current revision? 26492 is 3000 or so revisions ago and quite a few USB fixes have happened in the meantime.

comment:2 by clemens, 11 years ago

Maybe it is not a usb problem but a apic problem... I just tried the latest image and when I boot with a stick insert I'm able to get into kdb (it hangs after the last rocket icon)

Thread 72 "fxp intr handler"

but I'm still not be able to get into kdl when I plugin a stick in a running system.

comment:3 by umccullough, 11 years ago

Probably duplicate of #2084 and #2999

comment:4 by clemens, 11 years ago

Ah ok removing the ipro100 driver fix the usb problem but I have a ipro100, arrrg!

comment:5 by mmlr, 11 years ago

Blocked By: 2084 added
Resolution: duplicate
Status: newclosed

Closing as a duplicate of #2084 then.

Note: See TracTickets for help on using tickets.