Opened 11 years ago

Closed 5 years ago

#3436 closed bug (invalid)

NetSurf crashing

Reported by: Hubert Owned by: nobody
Priority: normal Milestone: R1
Component: Applications Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

rev. 29167 GCC4 (hybrid with support GCC2): NetSurf crashing when starting.

Attachments (3)

screenshot2.jpg (358.5 KB ) - added by Hubert 11 years ago.
netsurf_crash.txt (4.2 KB ) - added by Kev 7 years ago.
crash log on hrev44543
NetSurf-4794-debug-20-03-2013-03-25-56.report (5.3 KB ) - added by Kev 6 years ago.

Download all attachments as: .zip

Change History (13)

by Hubert, 11 years ago

Attachment: screenshot2.jpg added

comment:1 by mmlr, 11 years ago

Resolution: invalid
Status: newclosed

That's not a bug actually. NetSurf makes use of translators and these are loaded as add-ons into the address space of the application. Since they are GCC4 on a GCC4 install and you cannot mix GCC2 and GCC4 binaries, this is equivalent to not having any translators installed. It's not a crash either, it's just a bit of a strange error message.

comment:2 by iFrodo, 11 years ago

Resolution: invalid
Status: closedreopened

Wouldn't it be possible to have gcc4 compiled version of translators in /boot/beos/system/add-ons/gcc4 and makes gcc4 bins use them from it.

I suggest putting GCC4 add-ons on a subdirectory, instead of GCC2 ones, because for R5 compatibility, legacy apps expect to find add-ons on /boot/beos/system/add-ons/, so legacy add-ons (legacy means GCC2 compiled) should be in /boot/beos/system/add-ons/, and new GCC4 add-ons should then be relocated in a "gcc4" subdirectory.

This would allows to use GCC2 apps that make use of add-ons on a GCC4 compiled Haiku with GCC2 libs (hybrid build).

Is that a realistic suggestion??

comment:3 by iFrodo, 11 years ago

Ok I verified my suggestion and it should work.

How did I verified:

  • I installed the GCC2 compiled translators in /boot/home/config/add-ons/Translators
  • I tried NetSurf

And it worked! :)

Proof: http://bpresles.free.fr/NetSurf-BePDF-BeHappy-GCC4Hybrid.png

So it seems that even if the subdirectory suggestion wouldn't be faisable, installing GCC2 version of Translator with for example a "-gcc2" part in their names on the /boot/beos/system/add-ons/Translators/ will work.

I've also veryfied the last solution. I copied the GCC2 version of Translators with -gcc2 name (e.g: BPM-gcc2Translator) in /boot/beos/system/add-ons/Translators/ and it works also.

So a very quick fix to this issue (as it's not a bug), would seemly to include the installation of GCC2 Translators with "-gcc2" included in their names on /boot/beos/system/add-ons/Translators/ in the GCC2 additional library build process in a GCC4/GCC2 haiku build process.

I hope you will consider this suggestion, as it works, and allows to offer a better R5 compatibility (as good as with a GCC2 build? Maybe!!) in GCC4/GCC2 hybrid Haiku builds.

comment:4 by Hubert, 10 years ago

iFrodo: It's works. Thx. And I have even one problem with hybrid at this time: http://dev.haiku-os.org/ticket/3437

in reply to:  3 comment:5 by anevilyak, 10 years ago

Replying to iFrodo:

  • I installed the GCC2 compiled translators in /boot/home/config/add-ons/Translators
  • I tried NetSurf

That method however will quite likely break gcc4 apps that try to use translators in the same install.

comment:6 by axeld, 9 years ago

Owner: changed from axeld to nobody
Status: reopenedassigned
Version: R1/pre-alpha1R1/Development

comment:7 by Kev, 7 years ago

On GCC2-hybrid downloaded nightly hrev44543, I installoptionalpackage netsurf, then launch it from the menu. It crashes immediately (see attached log.)

by Kev, 7 years ago

Attachment: netsurf_crash.txt added

crash log on hrev44543

in reply to:  7 comment:8 by Kev, 6 years ago

On GCC2 hybrid hrev45385, crashing with attached log. Had to make symlinks for libjpeg and libpng for it to get this far, otherwise it complained they were missing. From Terminal it says:

/> /boot/apps/NetSurf/NetSurf find_resource() Unable to open Messages file .Kill Thread

comment:9 by Kev, 6 years ago

Fresh install, just did installoptionalpackage netsurf, and the symlinks.

BTW, the log has my processor wrong, I just noticed. It's a Sempron 3100+. Not sure if that makes any difference.

comment:10 by luroh, 5 years ago

Resolution: invalid
Status: assignedclosed

If necessary, let's pick this up again if a new NetSurf package becomes available, or when at least the versions of the tested software in question are known and stated in the ticket.

Note: See TracTickets for help on using tickets.