Opened 10 years ago

Closed 7 years ago

#3437 closed bug (fixed)

Video Lan Client don't play on a hybrid installation

Reported by: Hubert Owned by: axeld
Priority: normal Milestone: R1
Component: Applications Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: #4920 Blocking:
Has a Patch: no Platform: All

Description (last modified by diver)

hrev29167 GCC4 (hybrid with support GCC2), VLC don't play music (silent), Media Player play with noise. I use OSS driver. HDA driver causes problems for the time being.

Attachments (2)

screenshot5.jpg (264.2 KB) - added by Hubert 10 years ago.
screenshot4.jpg (250.4 KB) - added by Hubert 10 years ago.

Download all attachments as: .zip

Change History (18)

Changed 10 years ago by Hubert

Attachment: screenshot5.jpg added

Changed 10 years ago by Hubert

Attachment: screenshot4.jpg added

comment:1 Changed 10 years ago by leszek

Try perhaps the VLC 0.8.6d version. It seems to work much smoother than VLC 0.8.6c http://gaelstar.com/beos/

comment:2 Changed 10 years ago by Hubert

Thx. I use but it's the same. But now I run 0.8.6c with terminal:

/boot/apps/vlc-0.8.6c/VLC\ media\ player

VLC media player 0.8.6c Janus scrollview BView::InitData(): resizing mode or flags swapped [00000244] main playlist: nothing to play [00000244] main playlist: stopping playback BMediaEventLooper: SchedulingLatency is 0 BMediaRoster::SetTimeSourceFor: node 8 time source 2 enter BMediaRoster::SetTimeSourceFor: node 8 time source 2 leave BMediaRoster::Connect connection established! BMediaRoster::GetParameterWebFor Unflattening 1803 bytes, 0x01030506, 0x00000001, 0x00000002, 0x00000003 _SoundPlayNode::FillNextBuffer: RequestBuffer failed _SoundPlayNode::FillNextBuffer: RequestBuffer failed _SoundPlayNode::FillNextBuffer: RequestBuffer failed _SoundPlayNode::FillNextBuffer: RequestBuffer failed _SoundPlayNode::FillNextBuffer: RequestBuffer failed _SoundPlayNode::FillNextBuffer: RequestBuffer failed _SoundPlayNode::FillNextBuffer: RequestBuffer failed _SoundPlayNode::FillNextBuffer: RequestBuffer failed _SoundPlayNode::FillNextBuffer: RequestBuffer failed _SoundPlayNode::FillNextBuffer: RequestBuffer failed _SoundPlayNode::FillNextBuffer: RequestBuffer failed _SoundPlayNode::FillNextBuffer: RequestBuffer failed _SoundPlayNode::FillNextBuffer: RequestBuffer failed _SoundPlayNode::FillNextBuffer: RequestBuffer failed _SoundPlayNode::FillNextBuffer: RequestBuffer failed _SoundPlayNode::FillNextBuffer: RequestBuffer failed _SoundPlayNode::FillNextBuffer: RequestBuffer failed _SoundPlayNode::FillNextBuffer: RequestBuffer failed _SoundPlayNode::FillNextBuffer: RequestBuffer failed _SoundPlayNode::FillNextBuffer: RequestBuffer failed _SoundPlayNode::FillNextBuffer: RequestBuffer failed _SoundPlayNode::FillNextBuffer: RequestBuffer failed _SoundPlayNode::FillNextBuffer: RequestBuffer failed _SoundPlayNode::FillNextBuffer: RequestBuffer failed _SoundPlayNode::FillNextBuffer: RequestBuffer failed signal 2 received, terminating vlc - do it again in case it gets stuck _SoundPlayNode::FillNextBuffer: RequestBuffer failed _SoundPlayNode::FillNextBuffer: RequestBuffer failed _SoundPlayNode::FillNextBuffer: RequestBuffer failed _SoundPlayNode::FillNextBuffer: RequestBuffer failed _SoundPlayNode::FillNextBuffer: RequestBuffer failed _SoundPlayNode::FillNextBuffer: RequestBuffer failed _SoundPlayNode::FillNextBuffer: RequestBuffer failed _SoundPlayNode::FillNextBuffer: RequestBuffer failed _SoundPlayNode::FillNextBuffer: RequestBuffer failed _SoundPlayNode::FillNextBuffer: RequestBuffer failed TimeSourceObject::DeleteHook enter BMediaRoster::ReleaseNode, trying to release reference counting disabled timesource, node 2, port 245873, team 275 TimeSourceObject::DeleteHook leave [00000244] main playlist: stopping playback

BTW. Why haven't vlc 0.8.6d on BeBits or Haikuware?

comment:3 Changed 10 years ago by Hubert

Maybe really helped build VLC plugins or all VLC in gcc4?

comment:4 Changed 10 years ago by iFrodo

I can confirm the problem on GCC4 builds with GCC2 libs.

I thinks it's a similar cause to the Translators issue. If VLC is using the media kit, while the libmedia.so is indeed installed in both gcc2 and gcc4 version (on system/lib) the media add-ons are only provided in gcc4 version.

A good solution would be that all elements of the add-ons folders, for those which are used by as or by a shared lib, should be installed on the image in both gcc2 and gcc4 version. As it's already done for the system/lib libraries.

As a possible fix to the present issue (I didn't test yet), would be to copy the gcc2 media add-ons on home/config/add-ons/media (create the media folder if it doesn't exist).

I'll test this possible fix tonight and report. Do the same if you can :)

comment:5 Changed 10 years ago by iFrodo

Note that I can reproduce this issue not only in VLC, but also in Jukebox. And I guess every GCC2 apps using media kit and having audio output.

comment:6 Changed 10 years ago by anevilyak

No, this is actually unrelated to the translator issue. The reason translators are an issue is because the translation kit loads the translators directly into the app's address space. Media addons do not work this way, they're all loaded directly into media_addon_server, and apps using the media kit interact with them by sending messages back and forth with the media server. As a consequence they never directly interact with the addon symbols and there's no potential for a gcc2-4 interaction problem there. So whatever's going on in this case is something different.

comment:7 in reply to:  6 Changed 10 years ago by korli

Replying to anevilyak: That's true for media addons, but not for media plugins ie decoders and readers.

comment:8 Changed 10 years ago by iFrodo

Replying to korli: So maybe putting gcc2 compiled plug-ins in home/config/add-ons/media/plugins/ can help?

comment:9 Changed 10 years ago by iFrodo

Answering to myself: Sadly it doesn't work. Seems that this really is a bug that need investigation...

comment:10 Changed 10 years ago by iFrodo

After some tests, I've seen two distinct issues:

- For Jukebox, there is indeed an issue with media plugins, as it says :

PluginManager: Error, loading PlugIn aiff_reader failed sh: PluginManager:: command not found

And replacing GCC4 plugins by GCC2 plugins makes it find and load them just find (but then of course it's GCC4 apps (like MediaPlayer) that fail to load the plugins).

So for this issue, I guess the solution would be to do just like for the libs, which is having a gcc2 and a gcc4 folder with respectively gcc2 and gcc4 compiled plugins, and of course makes the media kit choose the right version depending if it's a gcc2 or a gcc4 apps trying to load the plugin.

- In both Jukebox (after temporarily solving the plugins issue) and VLC case (which doesn't seem to use media kit plugins at all, so not plugins issue for it), then there is still no sound and the following message keeps repeating itself:

_SoundPlayNode::SendNewBuffer, event scheduled much too late, lateness is 17967 _SoundPlayNode::FillNextBuffer: RequestBuffer failed _SoundPlayNode::FillNextBuffer: RequestBuffer failed _SoundPlayNode::FillNextBuffer: RequestBuffer failed _SoundPlayNode::FillNextBuffer: RequestBuffer failed _SoundPlayNode::FillNextBuffer: RequestBuffer failed _SoundPlayNode::FillNextBuffer: RequestBuffer failed

Hope this can help to solve this two sound/media issues.

comment:11 Changed 10 years ago by korli

Summary: Video Lan Client don't playVideo Lan Client don't play on a hybrid installation

comment:12 Changed 10 years ago by Adek336

Blocked By: 4893, 4920 added

comment:13 Changed 8 years ago by scottmc

Can you test this again with a more recent build?

comment:14 Changed 8 years ago by stargatefan

vlc works fines. Never tried jukebox???

comment:15 Changed 7 years ago by diver

Blocked By: 4893 removed
Description: modified (diff)

VLC works fine in hrev44036 gcc4h.

comment:16 Changed 7 years ago by diver

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.