Opened 11 years ago

Closed 11 years ago

#3442 closed bug (invalid)

Virturalbox Network adapters do not appear in Network Preferences

Reported by: jdiwnab Owned by: axeld
Priority: normal Milestone: R1
Component: Network & Internet/Stack Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

When running Haiku (revision 29155) in VirtualBox 2.10 and 2.12, running on Mac OS X and in Fedora 9, neither NAT nor Host network adapters appear in Network Preferences, and networking, such as internet access, does not work, appearing as if there is no network connection at all.

How to reproduce: Take the raw hdd image, and convert to VirtualBox VDI format using VBoxManage. Create a new VM in VirtualBox for Haiku. Setup NAT or Host networking for the VM. Start the VM, and observe lack of networking.

I would speculate that it would be caused by Haiku not having drivers for the virtual network adapters VirtualBox is providing.

Change History (2)

comment:1 by jdiwnab, 11 years ago

It appears as though it is just the PCnet-FAST III (Am79C973) adapter that doesn't work. The Intel PRO/1000 MT Desktop (82540EM) adapter type works. This further suggests a driver issue.

comment:2 by axeld, 11 years ago

Resolution: invalid
Status: newclosed

There just is no driver for this hardware. I'm closing this bug as invalid, I don't think we really need this driver anymore.

Note: See TracTickets for help on using tickets.