Opened 10 years ago

Closed 7 years ago

#3441 closed bug (fixed)

The zbeos never appears on my Screen (No colored Symbols)

Reported by: Xbertl Owned by: axeld
Priority: normal Milestone: R1
Component: System/Boot Loader Version: R1/Development
Keywords: Cc: starsseed@…, meianoite@…
Blocked By: #4408 Blocking:
Has a Patch: yes Platform: x86

Description (last modified by diver)

Hello,

I can't boot Haiku but I think I don't do anything wrong during the Haiku installation.

How I tried to install Haiku:

  1. flashnul (http://www.haiku-os.org/community/forum/how_to_install_haiku_to_usb_flash_drive_from_windows)
  2. From a beos based system. Copy to a Partition, makebootable and integrate in Bootman
  3. Using Virtualbox and Haiku. I configured virtualbox to have direct access to a physical HDD (Look in the Virtualbox manual point 9.9). Use "Installer", makbootable.


I tried 1 and 3 on an Intel Laptop and Haiku did boot on this machine. But on my machine the zbeos never appears. I only have a black screen with a blinking small white line in the top left corner.

My Hardware:
CPU: AMD Phenom X4 9550
Mainboard: MSI K9A2 Platinum (NB:790FX; SB:SB600) http://217.110.206.56/index.php?func=proddesc&prod_no=1332&maincat_no=1&cat2_no=171
GPU: Radeon X1950 Pro (RV570)

But I have the same Problem on an old PIII 800 with fujitsu-siemens server mainboard 440BX (On this machine I tried only installation methode 2) http://support.fujitsu-siemens.com/manuals/ShowDescription_KMT.asp?DokuID=202628

This guy has the same mainboard an the same problem
http://www.freelists.org/post/haiku-development/boot-issues-both-hdd-and-usb-stick-on-FX9850-cpu-based-system

Maybe I can do the serial connect thing from my Phenom machine do the PIII machine with beos on it. But is it meaningful on this early boot stage?

Attachments (5)

booting-haiku.mkv (463.3 KB) - added by Xbertl 9 years ago.
mbr.bin (268 bytes) - added by starsseed 8 years ago.
MBR boot code
MBRcode.diff (22.6 KB) - added by starsseed 8 years ago.
the source (should build fine now!)
ScreenAfterDD.jpg (219.5 KB) - added by Xbertl 8 years ago.
new_haiku_gpt_mbr (512 bytes) - added by meianoite 8 years ago.
Found the "remove attachment" button :)

Download all attachments as: .zip

Change History (53)

comment:1 Changed 10 years ago by tombhadAC

I had the same problem on a FSC Scenic xl-1107.

comment:2 Changed 10 years ago by scottmc

Try again once the R1Alpha1 images are available and post on update for us on this ticket.

comment:3 Changed 10 years ago by Xbertl

Now I have tested the new Alpha with the same Result. The same Black screen with the blinking small white line. I tried to boot it direct from the CD, and to install it first on a harddisk in the VirtualBox. I don't know what it can be, I also testet various bios settings.

comment:4 Changed 9 years ago by andrewz

I can boot on a Abit BH6 motherboard w/ PIII that uses the 440BX. So I think you can eliminate 440BX as root problem.

comment:5 Changed 9 years ago by Xbertl

Platform: Allx86

I tried to press ESC during the system is booting. But I can't see any debug output. I installed bootman on the bootmedium (with virtualbox), and the OS- List appears on my screen, I select Haiku and press ESC several times. But there is no debug output. Only "Loading Haiku" appears for a short time on the top left corner, and then there is only the blinking small white line in the upper left corner.

comment:6 Changed 9 years ago by euan

First off, you press space bar to get the zbeos menu. :)

Are u burning the raw image? I use DD for windows which works well.

I would try a couple of other USB sticks. I have a couple that I can't boot from at all.

On my PC I need to install the haiku raw image on both a partition and a usb stick to boot into haiku. Weird I know, but I guess it's because Haiku doesn't support my usb controller after the bios hands over control to haiku. So I select boot from usb, then in the zbeos menu I select the haiku on the harddrive...

comment:7 Changed 9 years ago by Xbertl

Maybe I didn't make myself clear. I can't go in this menu by pressing the spacebar, because the boot progress stops bevor it is possible to switch to this menu.

comment:8 Changed 9 years ago by bonefish

Just to be clear: Your BeOS-based machine is not Haiku? And you're running the system's makebootable or the Haiku version?

comment:9 in reply to:  8 Changed 9 years ago by bonefish

Replying to bonefish:

Just to be clear: Your BeOS-based machine is not Haiku? And you're running the system's makebootable or the Haiku version?

Er, machine -> system, of course.

Changed 9 years ago by Xbertl

Attachment: booting-haiku.mkv added

comment:10 Changed 9 years ago by Xbertl

I have made a small video (Codec = Theora) so every one can see what is happen when I try to boot haiku.

Haiku- Version: hrev35511-x86gcc4

For this video I installed haiku from a other HAIKU system on the HDD. To do this job i used the build in Haiku- Installer and the build in Haiku- DriveSetup. I pressed the "Write boot sector" button in the Haiku- Installer. The Bootman was also installed in haiku.

If i burn the cd image from http://haiku-files.org/cd/ on a cd, the result during booting is the same.

comment:11 Changed 9 years ago by bonefish

Component: - GeneralApplications/BootManager
Version: R1/pre-alpha1R1/Development

Since there's no message at all I would say it doesn't even enter the stage 1 boot loader.

comment:12 in reply to:  11 Changed 9 years ago by Xbertl

Replying to bonefish:

Since there's no message at all I would say it doesn't even enter the stage 1 boot loader.

I also think so, because there is no serial debug output.

comment:13 Changed 9 years ago by euan

I just got a new Sony Vaio Z11. It shows the same boot problems as above. I see the bios loading the CD (lots of progress dots: ........) then blankness. I've tried two USB sticks, with the raw image, and anyboot, as well as the bootable CD. All the same. I also tested with a GParted bootable usb image, which did work.

Looks like some sort of EFI boot mechanism is needed?

comment:14 Changed 9 years ago by starsseed

Blocked By: 4408 added
Component: Applications/BootManagerSystem/Boot Loader

Changed from Applications/BootManager to System/BootLoader since the problem occurs at boot-time with BootManager as well as with a standard MBR boot code.

comment:15 Changed 8 years ago by euan

with the 8th Jan 2011 nightly, I can now see a boot menu and even the boot splash screen. The pc then promptly reboots. After a long session of random boot menu option testing the cause is simply that the boot screen must be set to 800x600 or 640x480. The other modes available are 1024x768, which I presume is the default. If 1024x768 (any bpp) is set, or the option is not set the pc reboots. After a sucessful boot at say 640x480 the boot is nice enough to remember for next time, and the fault no longer occurs.

Some sort of memory allocation failure for the vesa framebuffer?

My laptop has hybrid graphics (intel / nvidia). I believe the system is using the nvidia chipset at boot, needs some ACPI hot swap magic to change modes apparently. I need to poke around further to identify what vga chip set is being used.

comment:16 Changed 8 years ago by euan

definitely a memory issue, as 1024x768@8 works @16 @32 don't. all 640x480 modes work, and 800x600@32 doesn't, but @8 and @16 are ok.

Sounds like a new ticket?

comment:17 Changed 8 years ago by Xbertl

Does not work for me.
I still have the same Problem.

Tested with: haiku-nightly-hrev40172-x86gcc4

comment:18 Changed 8 years ago by euan

OK, I've opened a ticket for my outstanding issue, #7092

comment:19 Changed 8 years ago by mmadia

Keywords: sbx00 added

comment:20 Changed 8 years ago by starsseed

Cc: starsseed@… added
Keywords: sbx00 removed

I completely rewrote an MBR boot code from scratch. It works on every system I have: especially a Dell latitude E6500 and a HP DC5100 (both had the bug).

I join the compiled MBR boot code for testing. Your comments are welcome.

You can install it with the following command:
dd if=mbr.bin of=YourBootableDiskDevicePath

Now I'm working to provide a patch.

Changed 8 years ago by starsseed

Attachment: mbr.bin added

MBR boot code

comment:21 Changed 8 years ago by starsseed

Has a Patch: set

Changed 8 years ago by starsseed

Attachment: MBRcode.diff added

the source (should build fine now!)

comment:22 Changed 8 years ago by Xbertl

Does not work for me. If I do it as described, or also if I copy the content of the file directly with "Disk Probe" to the HDD, I only become the message "No bootable active volume" when I try to boot on my real Hardware or with this Device in the Virtual- Box

comment:23 Changed 8 years ago by starsseed

@Xbertl
can you provide a screenshot showing DiskProbe and DriveSetup ?

Last edited 8 years ago by starsseed (previous) (diff)

Changed 8 years ago by Xbertl

Attachment: ScreenAfterDD.jpg added

comment:24 Changed 8 years ago by Xbertl

Here is the screenshot from after I did the dd thing. By the way, "/dev/disk/scsi/0/1/0/raw" is a real HDD.

comment:25 Changed 8 years ago by starsseed

@Xbertl
My "MBRcode.bin" Does not work for you because you don't have any partition table. In fact, you don't have a MBR.
your disk device is formated as a partition only device!

with DiskProbe write zeros to the 1024 firsts bytes of our disk (because of the fs-sniffer, you nead to clear 2 sectors to remove your BFS volume). Then reboot, create an Intel partitioning system on your device, and then a primary Active BFS partition onto it. Install MBRcode.bin again and run the Haiku's Installer... Does your problem still persists ?

comment:26 Changed 8 years ago by Xbertl

It did not work. If I do it as described, I have the blinking small white line again. It does not work for me, but if I run the Installer after the mbr.bin, does the Installer not overwrite the mbr.bin? Nevertheless, if I do the mbr.bin after the Installer again, I have the "No bootable active volume" again.

comment:27 Changed 8 years ago by starsseed

@all I tested "HP Pavillon dv6". It works now. The kernel boots, but I was not able to mount the USB-connected boot device (USB not supported).

@Xbertl Installer does not touch the MBR, it only writes the PBR (Partition boot record). So if you have the blinking cursor after the installation, and the message "No bootable active volume" after writing the MBR code again, I am almost sure that you don't have a partitioning system on your disk...

contact-me privately (starsseed[at]free[dot]fr) maybe I can help you.

comment:28 in reply to:  20 ; Changed 8 years ago by axeld

Replying to starsseed:

I completely rewrote an MBR boot code from scratch.

The MBR you replaced (as part of the writembr command) is not the one that was actually used in the intel partition module (unfortunately). Have you tried the original MBR in writembr as well before going through all the work?

Also, compared to the MBR in the intel module, you also discarded the GPT functionality from it; while this isn't really crucial at this point, it's also a nice extension.

comment:29 in reply to:  28 Changed 8 years ago by starsseed

Replying to axeld:

The MBR you replaced (as part of the writembr command) is not the one that was actually used in the Intel partition module (unfortunately). Have you tried the original MBR in writembr as well before going through all the work?

I know writembr\mbr.S is not used in the "intel partition module". it's used in the anyboot-image.
I tested both. Since neither writembr\mbr.S nor haiku_gpt_mbr.S (see #4028) are working for me, I replaced the MBR boot code in the anyboot-image and *also* in the "Intel partition module".

Also, compared to the MBR in the Intel module, you also discarded the GPT functionality from it; while this isn't really crucial at this point, it's also a nice extension.

haiku_gpt_mbr.S is known to have some issues. André Braga is working on it, but it's going to be a bit short for the next release.

NB : i removed the '$(TARGET_CC)' command in the jam file.
maybe, it would be better to just comment it (future use).

comment:30 Changed 8 years ago by meianoite

Cc: meianoite@… added

I'm attaching four binaries of the hybrid MBR/GPT loader, please see if the modifications help booting on your machines. Ticket #4028 has the updated source code.

On debug variants, if you see a 3-character message starting with an exclamation mark, those are non-fatal erros and the boot can proceed by striking any key on the keyboard.

validate variants check if the BIOS drive ID is valid for fixed disks. Some BIOSes might not like depending on the emulation mode, hence the default now being no-validate.

Please remember to copy only the first 440 bytes to the beginning of your disk or disk image (as in:

dd if=haiku_gpt_mbr{_variant} of={yourdisk} bs=1 count=440 conv=notrunc

)

I'm subscribing to this ticket, so please share your findings here.

A.

Last edited 8 years ago by meianoite (previous) (diff)

comment:31 Changed 8 years ago by diver

Description: modified (diff)

comment:32 Changed 8 years ago by starsseed

the 4 haiku_gtp_mbr_* fail on my DellE6500. they hang on the blinking cursor. Nothing is displayed
Sorry...

comment:33 Changed 8 years ago by meianoite

I'll prepare a version with plenty of tracing for you. Just let me know what's the last number on screen before it hangs.

comment:34 Changed 8 years ago by starsseed

haiku_gpt_mbr_debug_trace.2 repeat "1235684123568412356841235684123568412356841235684" indefinitely.

comment:35 Changed 8 years ago by meianoite

Hey, that's Progress! =D

But that also means that somehow the code is looping. I can't see how this would happen if not for loading the same sector over and over. Would you mind posting a hex dump of your MBR?

Also attaching a version with even more tracing and some instruction shuffling. Now it will print its progress at it tests for LBA read support. It will pause for a key press after the letter 'k' (for "Okay!) is printed.

Now the code is packed real tight. I'll have to give up some tracing points is we find that the latest changes don't help.

comment:36 Changed 8 years ago by meianoite

No more tracing. Guess I finally nailed the looping thing. Please try the attached version!

comment:37 Changed 8 years ago by starsseed

The latest MBR seems to work. (tested on ASRock 4CoreDual-SATA2_2 and Dell Latitude E6500. I will try to test more PC next week).

comment:38 Changed 8 years ago by meianoite

FWIW, the current hybrid MBR/GPT code was uploaded to ticket #4028. Will upload the latest binary here in a few moments.

Changed 8 years ago by meianoite

Attachment: new_haiku_gpt_mbr added

Found the "remove attachment" button :)

comment:39 in reply to:  37 Changed 8 years ago by meianoite

Replying to starsseed:

The latest MBR seems to work. (tested on ASRock 4CoreDual-SATA2_2 and Dell Latitude E6500. I will try to test more PC next week).

Awesome! Thanks for helping, Loïc!

comment:40 Changed 8 years ago by anevilyak

Resolution: fixed
Status: newclosed

Applied MBRCode.diff in hrev42104. Thanks!

comment:41 Changed 8 years ago by Xbertl

This ticket is not fixed. I have still the same problem, also if I installed the fix from starsseed the right way.

comment:42 Changed 8 years ago by Xbertl

Resolution: fixed
Status: closedreopened

comment:43 Changed 8 years ago by xsive

Not fixed for me either, tried alpha 3 and other nightly builds I still get the same blinking caret at the top and no boot screen and no ability to enter safe mode

comment:44 Changed 7 years ago by Xbertl

My system can boot now, thank you very much for your work.

Tested with:
x86 GCC 2 Hybrid
hrev42768 VMDK
Installed in Windows with Virtualbox on a Partition of a real hdd.

comment:45 Changed 7 years ago by starsseed

@XBertl
may be fixed by hrev42715 (better memory detection)

Last edited 7 years ago by starsseed (previous) (diff)

comment:46 Changed 7 years ago by Xbertl

Hello Starsseed,

no, it must be something what was committed between hrev41539 and hrev42421.
Because I tried several builds, and with hrev42421 my system is booting and with hrev41539 my system is not booting.

comment:47 Changed 7 years ago by xsive

Yes this works for me now too I suggest the problem is fixed on SB600 chipsets. Just have no usb devices working now but will open a new ticket

comment:48 Changed 7 years ago by axeld

Resolution: fixed
Status: reopenedclosed

Since the original problem seems to be fixed, I'm closing this one now.

Note: See TracTickets for help on using tickets.