Opened 10 years ago

Closed 7 months ago

#3486 closed bug (invalid)

PANIC: Did not found any boot partitions! (USB stick)

Reported by: fil Owned by: nobody
Priority: normal Milestone: R1
Component: System/Boot Loader Version: R1/pre-alpha1
Keywords: boot-failure Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Make DD on stick/image below and Haiku is unable to boot from it. Haiku start screen is shown, but when goes to HDD icon I have crash.

USB : Kingston DataTraveler 2 GB Booting from image : 29302 Computer : DEL Optiplex 740 Partitions : all non befs HDD: SATA (CD : SATA) Crash place : Haiku boot screen, icon for HDD

Debug console does not respond. Thread : 13 Func : main2

Booting in real hardware works just fine on same machine (with video Radeon HD 3650, integrated video card seems not supported yet).

Change History (11)

comment:1 Changed 10 years ago by fil

Today I've made some stupid test :) I've made partitions on USB stick. One boot haiku partition. Same result as above. Same result also when booting from same USB stick on computer with HDD which have bootable (but not active) haiku partition. Also it seems that haiku does not recognize USB stick at all after "makebootable" command over ext3/bfs USB stick partition. Don't know if haiku is intended to work with partitioned flash sticks.

comment:2 Changed 9 years ago by luroh

fil, got any updates on this one?

comment:3 Changed 9 years ago by fil

Has a Patch: unset

no. I have Haiku on SATA HDD and did not play with this any more. It may be fixed with new sources, I don't know. If you wish I can check it again with new images this days when I have time.

comment:4 Changed 9 years ago by luroh

Yes, please test again if you have a chance.

comment:5 Changed 8 years ago by scottmc

Can you recheck this with a recent Haiku build?

comment:6 Changed 8 years ago by scottmc

Blocking: 7665 added

comment:7 Changed 8 years ago by jedie

I get the same error: "PANIC: Did not found any boot partitions!" After booting from alpha3 CD-ROM... Have burned the anyboot-image (or similar)

EDIT: More info about the used hardware: https://dev.haiku-os.org/ticket/4526

Last edited 8 years ago by jedie (previous) (diff)

comment:8 Changed 2 years ago by axeld

Owner: changed from axeld to nobody
Status: newassigned

comment:9 Changed 12 months ago by waddlesplash

Keywords: boot-failure added

comment:10 Changed 12 months ago by waddlesplash

Blocking: 7665 removed

comment:11 Changed 7 months ago by waddlesplash

Resolution: invalid
Status: assignedclosed

No reply in a long time; EHCI issue is tracked in another ticket anyway.

Note: See TracTickets for help on using tickets.