Opened 11 years ago

Closed 4 years ago

#3498 closed enhancement (fixed)

When creating IMAP folders, also configure them by default such that their attribute view is suitable for viewing email

Reported by: anevilyak Owned by: axeld
Priority: low Milestone: R1
Component: Servers/mail_daemon Version: R1/Development
Keywords: mail folder Cc:
Blocked By: Blocking: #9462
Has a Patch: no Platform: All

Description

When new folders are created for an IMAP account to match those existing on the server, they currently show up by default like a normal tracker folder, which is to say filename / last modified by / size and such, which aren't generally as useful when trying to use MDR as intended. It would be nice if mail_daemon could preconfigure the directories such that a more suitable set of attributes appear when first opened.

Change History (7)

comment:1 by mounty, 6 years ago

Suggestion: ask the reporter to specify what attributes should appear in an email folder then merge this ticket with #9462.

comment:2 by anevilyak, 6 years ago

I'm not picky, I simply meant nothing more than setting them up the same way as e.g. /boot/home/mail/in.

comment:3 by mounty, 6 years ago

Specific instance: folders should show the extended attribute When, not the creation date of the mail item, which, in the case of a newly-discovered IMAP server, is irrelevant. In a mail folder, you want to see the date of the email, not when the file was created by the mail_daemon.

comment:4 by mounty, 6 years ago

Keywords: mail folder added

comment:5 by anevilyak, 6 years ago

Blocking: 9462 added

comment:6 by anevilyak, 6 years ago

Owner: changed from bga to axeld
Status: newassigned
Version: R1/pre-alpha1R1/Development

comment:7 by axeld, 4 years ago

Resolution: fixed
Status: assignedclosed

Implemented in hrev50030.

Note: See TracTickets for help on using tickets.