Opened 7 years ago

Closed 6 years ago

#9462 closed enhancement (duplicate)

sub-optimal functionality in mail system

Reported by: mounty Owned by: czeidler
Priority: low Milestone: R1
Component: Servers/mail_daemon Version: R1/Development
Keywords: mail folder Cc:
Blocked By: #3498 Blocking:
Has a Patch: no Platform: All

Description (last modified by axeld)

These are two suggestions to improve the way mail is handled.

  1. Folders should show the extended attribute When, not the creation date of the mail item, which, in the case of a newly-discovered IMAP server, is utterly irrelevant. In a mail folder, you want to see the date of the email, not when the file was created by the mail_daemon.
  1. An IMAP server with nested folders shows a flat dot-separated list of folders, rather than a hierachy. I know this reflects the raw structure, at least on a Dovecot database, but it's still not what I expect as a user. For example, I have a folder Incoming which contains one subfolder for each year: Incoming/2013, Incoming/2012 etc. In Haiku's folders, these are shown as Incoming.2013, Incoming.2012, all in one big list. What I would expect is just the folder Incoming, which, when clicked, opened a further folder window showing 2013, 2012 etc.

Change History (6)

comment:1 by axeld, 7 years ago

Thanks! It's preferred to use different tickets for different issues. In any case, my IMAP rework will cover 2.)

About 1.): Tracker will just take over the columns of the parent. The mail_daemon could easily install default columns whenever it creates a directory (or a query), though.

comment:2 by mounty, 6 years ago

#7990 is a duplicate of point (2) above. I'll leave it to czeidler to decide whether he wants to close #7990 as a duplicate or (bearing in mind that bugs should cover one point only (as stated by Axeld above)) he wants to remove point (2) above.

comment:3 by axeld, 6 years ago

Description: modified (diff)

Thanks for the note; I left 2.) to ticket #7990, and claimed it.

comment:4 by mounty, 6 years ago

#3498 appears to be a more general specification of this bug and probably should be subsumed into this ticket.

comment:5 by mounty, 6 years ago

I've added the description of this item to #3498 and suggest that this ticket be closed.

comment:6 by anevilyak, 6 years ago

Blocked By: 3498 added
Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.