Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#350 closed bug (fixed)

Spurious mouse movements

Reported by: jackburton Owned by: marcusoverhagen
Priority: normal Milestone: R1
Component: System/Kernel Version:
Keywords: Cc: diver, umccullough
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Since today's morning (28/03), every 4 seconds or so the mouse goes to the bottom left corner of the screen, and it looks like it gets false button hits.

Change History (15)

comment:1 by jackburton, 14 years ago

Sorry, should have specified that this happens at least under VMWare

comment:2 by korli, 14 years ago

Same on VirtualPC (without touching the mouse, there are movements and clicks)

comment:3 by korli, 14 years ago

Cc: korli@… added

comment:4 by axeld, 14 years ago

The same happens under Qemu as well.

comment:5 by axeld, 14 years ago

Confirmed on real hardware as well.

comment:6 by umccullough@…, 14 years ago

For me, this has been happening EVERY OTHER TIME I BOOT Haiku on real hardware for several weeks. I thought it was just a compatibility with my KVM switch at the time since it didn't seem to happen ever when I attached a mouse directly to the PS/2 port.

I never understood why it only happened every other time I booted - that suggests that something was left in a bad state from the previous boot.

comment:7 by jackburton, 14 years ago

I have fixed this in hrev16915 by commenting out some code. Marcus, shall I close the bug, or should I wait for you to finish with hotplug support ?

comment:8 by marcusoverhagen, 14 years ago

Status: newassigned

comment:9 by umccullough@…, 14 years ago

The issue I mentioned is gone now also in hrev16939.

comment:10 by diver, 14 years ago

Cc: diver added

comment:11 by diver, 14 years ago

Should we close this bug?

comment:12 by marcusoverhagen, 14 years ago

Cc: umccullough@… added

comment:13 by marcusoverhagen, 14 years ago

I'm closing this bug now, as the hotplug support that was reason for the spurious mouse movement every 4 seconds, has been modified to no longer actively poll the mouse. It monitors now the keyboard controller reporting hotplug events.

If someone still experiences spurious mouse movements, they are not related to this original bug description. Please open a new bug report if required.

comment:14 by marcusoverhagen, 14 years ago

Status: assignedclosed

comment:15 by marcusoverhagen, 14 years ago

Resolution: fixed
Note: See TracTickets for help on using tickets.