Opened 10 years ago

Closed 2 years ago

#3597 closed bug (not reproducible)

checkfs fails to check one specific partition.

Reported by: adamk Owned by: axeld
Priority: high Milestone: R1
Component: File Systems/BFS Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I have a Haiku partition on /dev/disk/ata/0/master/3 (named Builder) and one on /dev/disk/usb/0/0/raw (named USB). If I try to run checkfs on Builder, whether I specify the volume name or the device path, and whether Builder or USB is the root drive, I get:

-> checkfs /dev/disk/ata/0/master/3 checkfs: Could not prepare the device for modifications: Invalid Argument

I was unable to run mkfs on it while running on USB (general OS error, iirc), so I booted off a BeOS CD, reinitialized the partition, and then copied my data back over. Only I still get the same error.

I can run checkfs on USB.

I have no reason to believe that the filesystem is screwed up on Builder, but I have had a number of crashes recently so I wanted to check the filesystem anyway. I'm putting this under "File Systems/BFS" since that seems like the most likely culprit.

I'm attaching the serial debug log.

Attachments (2)

haiku-checkfs-debug.txt (118.3 KB) - added by adamk 10 years ago.
Serial debug log
Recent_BFS_Errors.txt (6.9 KB) - added by kallisti5 8 years ago.
my recent BFS errors due to use and abuse.

Download all attachments as: .zip

Change History (6)

Changed 10 years ago by adamk

Attachment: haiku-checkfs-debug.txt added

Serial debug log

comment:1 Changed 10 years ago by adamk

You can close this. I had to repartition that drive anyway, and now everything is fine.

comment:2 Changed 10 years ago by korli

Resolution: invalid
Status: newclosed

comment:3 Changed 8 years ago by kallisti5

Resolution: invalid
Status: closedreopened
Version: R1/pre-alpha1R1/Development

I am reopening this one as I have seen it as well.

After quite a few unexpected power losses (doing driver development, lots of KDL's) the Be file system itself starts causing random KDL's (unrelated to my driver development, without my drivers loaded)

~> uname -a
Haiku shredder 1 r39915 Dec 21 2010 15:44:58 BePC Haiku
~> checkfs /Data
checkfs: Could not prepare the device for modifications: Invalid Argument
~> checkfs /Haiku
checkfs: Could not prepare the device for modifications: Invalid Argument
~> checkfs /boot
checkfs: Could not prepare the device for modifications: Invalid Argument

attaching Recent_BFS_Errors showing my most recent BFS error messages.

I will probbably reformat tomorrow as I want to get back to work.

Thanks!

Changed 8 years ago by kallisti5

Attachment: Recent_BFS_Errors.txt added

my recent BFS errors due to use and abuse.

comment:4 Changed 2 years ago by axeld

Resolution: not reproducible
Status: reopenedclosed

The provided info does not suffice to be able to find the cause for this. The most obvious reason for a problem like this would be if the BFS disk device add-on was corrupted; at that point, nothing BFS specific is happening yet AFAICT.

I'm closing this ticket for now; please reopen it if you have more information, or are even able to provide a debug session on a system that shows it.

Note: See TracTickets for help on using tickets.