Opened 10 years ago

Closed 10 years ago

#3604 closed bug (invalid)

[Trac Bug] AttributeError: 'NoneType' object has no attribute 'split'

Reported by: leavengood Owned by: nielx
Priority: normal Milestone: R1
Component: Website/Trac Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

This came up when I tried to do what is below.

How to Reproduce

While doing a POST operation on /ticket/3420, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{'__FORM_TOKEN': u'3df7ed8e8400de20682ca6c5',
 'action': u'reassign',
 'action_reassign_reassign_owner': u'leavengood',
 'cnum': u'1',
 'comment': u"I support this ticket and will take ownership. I'll need more cursors to properly port WebKit. Maybe not all the cursors needed by WebKit should be standard, but a lot could be. Here is a list from WebKit's Cursor.h (http://trac.webkit.org/browser/trunk/WebCore/platform/Cursor.h):\r\n\r\n\r\n{{{\r\nconst Cursor& pointerCursor();\r\nconst Cursor& crossCursor();\r\nconst Cursor& handCursor();\r\nconst Cursor& moveCursor();\r\nconst Cursor& iBeamCursor();\r\nconst Cursor& waitCursor();\r\nconst Cursor& helpCursor();\r\nconst Cursor& eastResizeCursor();\r\nconst Cursor& northResizeCursor();\r\nconst Cursor& northEastResizeCursor();\r\nconst Cursor& northWestResizeCursor();\r\nconst Cursor& southResizeCursor();\r\nconst Cursor& southEastResizeCursor();\r\nconst Cursor& southWestResizeCursor();\r\nconst Cursor& westResizeCursor();\r\nconst Cursor& northSouthResizeCursor();\r\nconst Cursor& eastWestResizeCursor();\r\nconst Cursor& northEastSouthWestResizeCursor();\r\nconst Cursor& northWestSouthEastResizeCursor();\r\nconst Cursor& columnResizeCursor();\r\nconst Cursor& rowResizeCursor();\r\nconst Cursor& middlePanningCursor();\r\nconst Cursor& eastPanningCursor();\r\nconst Cursor& northPanningCursor();\r\nconst Cursor& northEastPanningCursor();\r\nconst Cursor& northWestPanningCursor();\r\nconst Cursor& southPanningCursor();\r\nconst Cursor& southEastPanningCursor();\r\nconst Cursor& southWestPanningCursor();\r\nconst Cursor& westPanningCursor();\r\nconst Cursor& verticalTextCursor();\r\nconst Cursor& cellCursor();\r\nconst Cursor& contextMenuCursor();\r\nconst Cursor& noDropCursor();\r\nconst Cursor& notAllowedCursor();\r\nconst Cursor& progressCursor();\r\nconst Cursor& aliasCursor();\r\nconst Cursor& zoomInCursor();\r\nconst Cursor& zoomOutCursor();\r\nconst Cursor& copyCursor();\r\nconst Cursor& noneCursor();\r\nconst Cursor& grabCursor();\r\nconst Cursor& grabbingCursor();\r\n}}}\r\n",
 'field_blockedby': u'',
 'field_blocking': u'',
 'field_component': u'Kits/Application Kit',
 'field_description': u'It would be nice, if the Application Kit would provide more standard cursors, in order to prevent every app developer to come up with its own variation of cursors (e.g. cross-hair, grab, ...).\r\n\r\nThis would help to keep consistency and easy of use, as users don\'t have to learn new cursors for every application.\r\n\r\nThe cursors defined in the various Haiku applications like Icon-O-Matic could be used as a starting point. of course not all make sense as "standard", but I trust you to know which ones should be common among applications.',
 'field_keywords': u'',
 'field_milestone': u'R1',
 'field_platform': u'All',
 'field_priority': u'normal',
 'field_summary': u'Provide more standard cursors (etc. cross hair, grab, ...)',
 'field_type': u'enhancement',
 'field_version': u'R1 development',
 'id': u'3420',
 'preview': u'Preview',
 'replyto': u'',
 'ts': u'2009-02-08 10:54:23+00:00'}

User Agent was: Mozilla/5.0 (X11; U; Linux i686; en; rv:1.9.0.7) Gecko/20080528 Epiphany/2.22 Firefox/3.0

System Information

Trac 0.11.3
Python 2.4.3 (#1, Mar 14 2007, 18:51:08)
[GCC 4.1.1 20070105 (Red Hat 4.1.1-52)]
setuptools 0.6c9
psycopg2 2.0.6 (dec dt ext pq3)
Genshi 0.5.1
mod_python 3.3.1
Pygments 1.0
Subversion 1.4.2 (r22196)
jQuery: 1.2.6

Python Traceback

Traceback (most recent call last):
  File "/home/haiku/lib/python2.4/site-packages/Trac-0.11.3-py2.4.egg/trac/web/main.py", line 435, in _dispatch_request
    dispatcher.dispatch(req)
  File "/home/haiku/lib/python2.4/site-packages/Trac-0.11.3-py2.4.egg/trac/web/main.py", line 205, in dispatch
    resp = chosen_handler.process_request(req)
  File "/home/haiku/lib/python2.4/site-packages/Trac-0.11.3-py2.4.egg/trac/ticket/web_ui.py", line 182, in process_request
    return self._process_ticket_request(req)
  File "/home/haiku/lib/python2.4/site-packages/Trac-0.11.3-py2.4.egg/trac/ticket/web_ui.py", line 531, in _process_ticket_request
    get_reporter_id(req, 'author'), field_changes)
  File "/home/haiku/lib/python2.4/site-packages/Trac-0.11.3-py2.4.egg/trac/ticket/web_ui.py", line 1260, in _insert_ticket_data
    self._render_property_changes(req, ticket, field_changes)
  File "/home/haiku/lib/python2.4/site-packages/Trac-0.11.3-py2.4.egg/trac/ticket/web_ui.py", line 1310, in _render_property_changes
    resource_new)
  File "/home/haiku/lib/python2.4/site-packages/Trac-0.11.3-py2.4.egg/trac/ticket/web_ui.py", line 1344, in _render_property_diff
    old_list, new_list = old.split(), new.split()
AttributeError: 'NoneType' object has no attribute 'split'

Change History (3)

comment:1 Changed 10 years ago by nielx

Owner: changed from haiku-web to nielx
Status: newassigned

Were/are you able to reproduce this?

comment:2 Changed 10 years ago by leavengood

I have not seen this since it happened. I tried posting the same comment again on that bug and it worked this time, so I guess you can drop this.

comment:3 Changed 10 years ago by nielx

Resolution: invalid
Status: assignedclosed

Please reopen if it happens again!

Note: See TracTickets for help on using tickets.