Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#3631 closed enhancement (fixed)

patch : Build on BeOS or Zeta

Reported by: mmadia Owned by: bonefish
Priority: normal Milestone: R1
Component: Build System Version:
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I do not intend this patch to be committed. Rather it is being posted for convenience to the few people who use BeOS or Zeta to compile Haiku. I realize that building a new version of the cross-compiler would be ideal, but making one is understandably a low priority for most people.

This patch changes the compiler check from 081024 to 080323.

Link to 080323 compiler for BeOS and Zeta : http://haiku.mlotz.ch/haiku_cross_compiler_bone_2.95.3-haiku-080323.zip

Attachments (2)

configure-080323compiler.patch (413 bytes) - added by mmadia 10 years ago.
configure-080323compiler-rev2.patch (899 bytes) - added by mmadia 10 years ago.
untested, proposed patch.

Download all attachments as: .zip

Change History (13)

Changed 10 years ago by mmadia

comment:1 Changed 10 years ago by anevilyak

The problem is that if they then try to do development on a Haiku built with that compiler, it will have BEOS defined, unlike one built with the current cross compiler. This could quite easily confuse configure scripts, etc. software that has since been ported to Haiku under the assumption that they are two distinct platforms as they currently are.

comment:2 Changed 10 years ago by mmadia

Ah. I was not previously aware of that fundamental change between compiler versions.

comment:3 Changed 10 years ago by stippi

No, that's not the case. The compiler they built Haiku with does not matter once Haiku has been built. Once inside Haiku, they will use the current compiler from the Development package, which doesn't define BEOS anymore.

comment:4 Changed 10 years ago by anevilyak

Whoops, good catch. If that's the case though, why require the newer one in the build system's configure script? I'm quite certain that's the only difference between the two toolchains.

comment:5 Changed 10 years ago by mmadia

would a patch that detects BeOS and Zeta and set the value of haikuRequiredLegacyGCCVersion to 080323 be acceptable for svn?

something like :

if [ BeOS-or-Zeta ] ; then 
	haikuRequiredLegacyGCCVersion="2.95.3-haiku-080323"
	# TODO : update BeOS's cross-compiler.  low priority.
else
	haikuRequiredLegacyGCCVersion="2.95.3-haiku-081024"
fi 
export haikuRequiredLegacyGCCVersion
	# version of legacy gcc required to build haiku

Changed 10 years ago by mmadia

untested, proposed patch.

comment:6 Changed 10 years ago by bonefish

I don't like it. The build will break with the old compiler eventually, or even worse, it will succeed and produce other code than the official compiler. So if someone wants to build with the old compiler, they can by explicitly commenting out the check in configure, but that isn't an officially supported method to build Haiku.

comment:7 Changed 10 years ago by mmadia

Understandable. Can this ticket be set to "wontfix" or "invalid"?

comment:8 Changed 10 years ago by bonefish

I don't mind either way. We can keep the ticket open until someone updates the cross compiler for BeOS. I won't do it and if no-one else is interested, we can close it as well.

comment:9 Changed 10 years ago by mmlr

Resolution: fixed
Status: newclosed

There http://haiku.mlotz.ch/haiku_cross_compiler_bone_2.95.3-haiku-081024.zip

Updated the two places I know that point to this location being the getting and building instructions on the website and the file in the userguide that is based on it.

comment:10 Changed 10 years ago by umccullough

I also updated the following two pages which were linking to the old version:

http://www.haiku-os.org/documents/dev/haiku_development_getting_started http://www.haiku-os.org/development

(yay for disorganized documentation!)

comment:11 Changed 10 years ago by haiqu

Awesome work, thanks guys!

Note: See TracTickets for help on using tickets.