Opened 11 years ago

Closed 10 years ago

#3632 closed bug (fixed)

Freeze after ~1h 15min uptime (reproduceable)

Reported by: michael.weirauch Owned by: axeld
Priority: normal Milestone: R1
Component: System Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

My system freezes reproduceably after 1 hour 15 minutes of uptime.

Boot Haiku, disable screensaver and open About to see the uptime. Just leaving the system idling. Intermediate interaction with the system does not affect/delay the freeze. Nothing to see in the syslog.

This can be reproduced on a gcc2 as also on a gcc4 system. Any pointers on how I can help debug this problem are very welcome!

Environment: any Haiku rev up until now (tested since 2008-11) System: Thinkpad T500 (NK13AGE), C2D T9600@2.8Ghz, 4GB DDR3, 320GB SATA, VESA

I am unsure if classifying this issue for the kernel is correct. Perhaps issue 2572 (entering KDL) is related? (No syslog output at all, though.)

Michael

Attachments (5)

listdev-29784.txt (4.4 KB ) - added by michael.weirauch 11 years ago.
listdev Thinkpad T500 (NK13AGE)
kdl-ints-r29784-small.jpg (412.9 KB ) - added by michael.weirauch 11 years ago.
KDL ints Thinkpad T500 (NK13AGE)
kdl-ints-r29784-1h03m48s.jpg (311.8 KB ) - added by michael.weirauch 11 years ago.
kdl-ints-r29784-1h08m59s.jpg (331.5 KB ) - added by michael.weirauch 11 years ago.
kdl-ints-r29784-1h14m30s.jpg (339.0 KB ) - added by michael.weirauch 11 years ago.

Download all attachments as: .zip

Change History (23)

comment:1 by mmadia, 11 years ago

Attaching the output of listdev in Terminal and ints in KDL should be useful.

by michael.weirauch, 11 years ago

Attachment: listdev-29784.txt added

listdev Thinkpad T500 (NK13AGE)

by michael.weirauch, 11 years ago

Attachment: kdl-ints-r29784-small.jpg added

KDL ints Thinkpad T500 (NK13AGE)

comment:2 by bonefish, 11 years ago

Can you still enter the kernel debugger (F12)?

comment:3 by michael.weirauch, 11 years ago

No. The whole system is completely frozen.

Michael

PS: I am still investigating another issue on my system where it freezes reproduceably after some minutes (up to 5) of compiling the blender tree where the same observation - as in a frozen system - can be made. Dunno if these are related. (CPU and IO usage instead of idling here)

Worth filing another ticket?

comment:4 by ithamar, 11 years ago

@Michael:

Have you tried to disable the firewire stack and see what that does? Both your SATA as well as your USB 1&2 controllers are all using the same interrupt, and the firewire code is notoriously bad in interrupt handling, afaik.

anyway, try and removing those and see if it helps....

comment:5 by michael.weirauch, 11 years ago

@Ithamar

I already removed the firewire and ipro1000 driver from the image for testing purposes so that only ahci (SATA) and USB are sharing IRQ11, but no difference. I also switched the SATA controller into compat mode so that IRQ14&15 are used and IRQ11 is only left for USB. Doesn't help when its up to reproduce the freeze on compile. Haven't yet found the "time" on reproducing the freeze after 1h 15mins. Will do so today. Just need to find some distraction then ;)

by michael.weirauch, 11 years ago

by michael.weirauch, 11 years ago

by michael.weirauch, 11 years ago

comment:6 by michael.weirauch, 11 years ago

hrev29784; SATA/AHCI, USB and NIC on IRQ11; firewire bus manager and fw_raw taken out

  1. F12 after boot, making sure fw is out
  2. F12 http://dev.haiku-os.org/attachment/ticket/3632/kdl-ints-r29784-1h03m48s.jpg
  3. F12 http://dev.haiku-os.org/attachment/ticket/3632/kdl-ints-r29784-1h08m59s.jpg
  4. F12 http://dev.haiku-os.org/attachment/ticket/3632/kdl-ints-r29784-1h14m30s.jpg
  5. freeze on 1h19m40s

1h19m? Either the visits to KDL delay the freeze, or: (guessing ignorantly in any direction currently) The screensaver ran ~5 minutes before I noticed it wasn't turned off.

Do the handled interrupt figures tell about strange things going on?

comment:7 by michael.weirauch, 11 years ago

update: hrev30230; gcc4: still reproduceable with freeze after 1h16m53s and 1h16m49s

comment:8 by axeld, 11 years ago

Have you tried removing the sound driver?

The other theory I would have is that the BIOS tries to change some system configuration, and Haiku does not like the interference. Have you enabled ACPI? And if not, have you tried to enable it to see if that makes any difference? If yes, does disabling it change anything?

comment:9 by michael.weirauch, 11 years ago

In revs before and some after hrev29784 the hda driver was not in the image, yet. This can be excluded IMHO.

Currently do have acpi disabled (default). Something else to take care of except enabling it in the kernel config file?

comment:10 by axeld, 11 years ago

As long as you didn't have the OpenSound driver installed before :-)

About ACPI: changing the kernel settings file is all you have to do to enable it.

comment:11 by michael.weirauch, 11 years ago

No OpenSound ;)

ACPI: That's been it! hrev30266; new-ata-bm; acpi enabled: left the system running during night. No freeze and system ran for more then 8 hours!

Then tried to mount my storage partition for quickly testing #3772 but system froze on mount via Tracker. (No KDL, no KDL-enter)

comment:12 by bga, 11 years ago

I din' t measure time, but my system also freezes after some time. So far it only happened if I left it idle and I never saw it while actually using the system. When I notice it hanged, the monitor is completely black and keyboard/mouse got turned off (their lights are off). I can not enter KDL either but this could be just because keyboard is dead at this point.

comment:13 by bga, 11 years ago

Forgot tyo mention that this did not use to happen. I kept my computer on in haiku overnight without problems. Not anymore.

comment:14 by bga, 11 years ago

Ok, what I described just happened to me and it was definitely USB keyboard/mouse dying. The system was very well alive. Michael, could this also be the case for you? If so, maybe this bug should be assigned to mmlr. If not, I will open a different bug about this.

comment:15 by michael.weirauch, 11 years ago

Hi Bruno,

I am not sure your observations are similar to mine. My system is frozen completely. (no keyb/mouse, KDL and the about window uptime update). I can't judge about the system "alive" status. It's at least visually frozen.

The test I performed with ACPI enabled at least helped with it. Don't wan't to close the bug yet, though.

comment:16 by michael.weirauch, 11 years ago

Btw, my trackpoint and touchpad are PS2-attached. They don't react upon freeze, either. So I guess your observations are more USB-centric.

comment:17 by michael.weirauch, 10 years ago

hrev35738 gcc4h is now up since 4h52m.

As this one seems closely related to #3772 and hrev35736 fixed it, I'd consider this one fixed as well. Thanks!

comment:18 by stippi, 10 years ago

Resolution: fixed
Status: newclosed

Very nice. Thanks for the update.

Note: See TracTickets for help on using tickets.