Opened 10 years ago

Closed 10 years ago

#3642 closed bug (duplicate)

Tracker crashes when Expander attempts to unzip a zip file

Reported by: Disreali Owned by: axeld
Priority: normal Milestone: R1
Component: - General Version: R1/pre-alpha1
Keywords: Cc: mdisreali@…
Blocked By: #3710 Blocking:
Has a Patch: no Platform: x86

Description

System Info:

Haiku pre-alpha-hrev29796-vm running in VirtualBox 2.14 on a Ubuntu 8.04 Host system. 512MB Allocated to vm

Steps to Produce:

Startup fresh vm of hrev29796. Start Bezilla Browser and downloaded Beshare2.28.zip from BeBits.com. File downloaded to /boot/home/downloads/. Double-click on BeShare2.28.zip, check 'Show Contents' on Expander, and the click the Expand button. Tracker crashes. Error msg: "The application /boot/beos/system/Tracker "crashed" appears.

Reproducible: yes

Attachments (2)

Screenshot-2.png (322.9 KB) - added by Disreali 10 years ago.
Screenshot-5.png (219.8 KB) - added by Disreali 10 years ago.

Download all attachments as: .zip

Change History (9)

Changed 10 years ago by Disreali

Attachment: Screenshot-2.png added

Changed 10 years ago by Disreali

Attachment: Screenshot-5.png added

comment:1 Changed 10 years ago by aldeck

I can't reproduce here.
Can you reproduce it everytime?
Apparently the crash happens when drawing the column titles (for the folder "/boot/home/downloads"). Anything special you did with the columns? Changing width, order, adding extra attributes or anything else.

comment:2 in reply to:  1 Changed 10 years ago by Disreali

I'll open Vbox and check.

Yes. I created the /boot/home/downloads/ dir and added the 'Kind' attribute column in /boot/home/. I then moved it to between the 'Size' and "Modified'. I then did the same in /boot/home/downloads/. I also adjusted the widths of all 4 columns, so that nothing was truncated. It is an old habit from my BeOS days.

Should I change the bug Summary?

comment:3 Changed 10 years ago by Disreali

Cc: mdisreali@… added

comment:4 Changed 10 years ago by Disreali

I have not experienced this issue in a long time. Should it be closed?

comment:5 Changed 10 years ago by aldeck

Resolution: fixed
Status: newclosed

Yes, looking at the screenshots, it was most certainly a dup of #3710. Thanks for the update.

comment:6 Changed 10 years ago by aldeck

Resolution: fixed
Status: closedreopened

changing resolution to duplicate

comment:7 Changed 10 years ago by aldeck

Blocked By: 3710 added
Resolution: duplicate
Status: reopenedclosed
Note: See TracTickets for help on using tickets.