Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#3686 closed bug (invalid)

daily raw image broken

Reported by: BeOSR Owned by: axeld
Priority: normal Milestone: R1
Component: System Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Daily raw image is broken and unbootable. This is the case for R29957 and R29912 of April 5th and 4th respectively. R29796 worked just fine.

System folder is now placed in /boot instead of /boot/beos and lacks the file zbeos. Several other folders are also misplaced in /system instead of /beos and/or other locations. Putting them in their right places and rebooting throws me in KDL at first boot icon.

Running native on ATA disk, by mounting raw image in R5 and copying content to prepared Haiku partition. This worked without problem until now.

Change History (3)

comment:1 Changed 10 years ago by anevilyak

Resolution: invalid
Status: newclosed

The image itself boots fine. The change in directory hierarchy was deliberate, and if you're writing the boot sector from R5, it's looking for files that are no longer where it expects in Haiku, since the way you're installing it isn't really supported anyways. For one the haiku loader is also no longer called zbeos. See hrev29876.

comment:2 Changed 10 years ago by stippi

Someone already attached the Haiku makebootable binary you need to use on BeOS (ie Haiku's makebootable compiled for BeOS) to another ticket about this issue. I am too lazy to search for the ticket in Trac, if you can't find it, maybe ask in #haiku on IRC.

comment:3 Changed 10 years ago by BeOSR

Thanks, must have missed that. Found the binary, will be trying the workarounds later.

Note: See TracTickets for help on using tickets.