Opened 10 years ago

Closed 10 years ago

#3687 closed bug (fixed)

app_server crash while moving Firefox between workspaces

Reported by: anevilyak Owned by: axeld
Priority: normal Milestone: R1
Component: Servers/app_server Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description (last modified by anevilyak)

I just got this crash with hrev29979 about 1 seconds after moving FF to a new workspace:

791: DEBUGGER: getNumAvailable() == 0
debug_server: Thread 791 entered the debugger: Debugger call: `getNumAvailable() == 0'
stack trace, current PC 0xffff0104  :
  (0x70697474)  0x660ad9  __assert_fail + 0x51
  (0x706974a4)  0x66af98  malloc__Q28BPrivate10threadHeapUl + 0x4a0
  (0x706974f4)  0x66b8ec  malloc + 0x154
  (0x70697524)  0x655bbd  __nw__FUlRC9nothrow_t + 0x29
  (0x70697554)  0x28ac5c  ScreenAndUserClipping__C4ViewP7BRegionb + 0x68
  (0x70697594)  0x28db28  GetEffectiveDrawingRegion__6WindowP4ViewR7BRegion + 0xd4
  (0x706975cc)  0x286f68  _UpdateCurrentDrawingRegion__12ServerWindow + 0x54
  (0x706975fc)  0x282b38  _DispatchViewDrawingMessage__12ServerWindowlRQ28BPrivate12LinkReceiver + 0xb0
  (0x70698c3c)  0x282836  _DispatchViewMessage__12ServerWindowlRQ28BPrivate12LinkReceiver + 0x215a
  (0x70698ddc)  0x280621  _DispatchMessage__12ServerWindowlRQ28BPrivate12LinkReceiver + 0x1239
  (0x70698f0c)  0x286482  _MessageLooper__12ServerWindow + 0x282
  (0x70698f7c)  0x268978  _message_thread__13MessageLooperPv + 0x28
  (0x70698fac)  0x65bcd8  thread_entry + 0x20

Unfortunately I'm uncertain as to how easy that one will be to reproduce, and I don't see anything suspicious on serial log prior to it crashing into gdb.

Change History (6)

comment:1 Changed 10 years ago by anevilyak

Description: modified (diff)

comment:2 Changed 10 years ago by stippi

Yes, I also saw a memory corruption bug (also to do with clipping). Maybe it's caused by my recent changes.

comment:3 Changed 10 years ago by anevilyak

Just saw another one while playing with the new volume slider, not sure if it's related or not: {{{ vm_page_fault: vm_soft_fault returned error 'Bad address' on fault at 0x0, ip 0x800d7a84, write 0, user 0, thread 0x95 debug_server: Thread 149 entered the debugger: Segment violation stack trace, current PC 0x273ca6 ClientTeamC9ServerApp + 0x6:

(0x704d1d2c) 0x24f77e SetFocusWindow7DesktopP6Window + 0x1aa (0x704d1d7c) 0x25007c ActivateWindow7DesktopP6Window + 0x3b0 (0x704d1ddc) 0x27f6ca _DispatchMessage12ServerWindowlRQ28BPrivate12LinkReceiver + 0x2e2 (0x704d1f0c) 0x286482 _MessageLooper12ServerWindow + 0x282 (0x704d1f7c) 0x268978 _message_thread13MessageLooperPv + 0x28 (0x704d1fac) 0x65ccd8 thread_entry + 0x20

}}}

comment:4 Changed 10 years ago by anevilyak

Bah. Make that:

vm_page_fault: vm_soft_fault returned error 'Bad address' on fault at 0x0, ip 0x800d7a84, write 0, user 0, thread 0x95
debug_server: Thread 149 entered the debugger: Segment violation
stack trace, current PC 0x273ca6  ClientTeam__C9ServerApp + 0x6:
  (0x704d1d2c)  0x24f77e  SetFocusWindow__7DesktopP6Window + 0x1aa
  (0x704d1d7c)  0x25007c  ActivateWindow__7DesktopP6Window + 0x3b0
  (0x704d1ddc)  0x27f6ca  _DispatchMessage__12ServerWindowlRQ28BPrivate12LinkReceiver + 0x2e2
  (0x704d1f0c)  0x286482  _MessageLooper__12ServerWindow + 0x282
  (0x704d1f7c)  0x268978  _message_thread__13MessageLooperPv + 0x28
  (0x704d1fac)  0x65ccd8  thread_entry + 0x20

comment:5 Changed 10 years ago by anevilyak

Haven't encountered this any more in probably a month and a half. I don't recall seeing an obvious change that would have had an impact though. Should I close for now and reopen if I see it again?

comment:6 Changed 10 years ago by axeld

Resolution: fixed
Status: newclosed

I guess we could do that - around BeGeistert, you could crash the app_server easily. While I don't remember seeing any fixes in this area, it seems the bug is no longer there.

Note: See TracTickets for help on using tickets.