Opened 10 years ago

Closed 6 years ago

#3693 closed bug (fixed)

Daylight saving change on wrong day

Reported by: haiqu Owned by: stippi
Priority: normal Milestone: R1
Component: User Interface Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

In Australia, daylight savings time ends at 3:00am on the first Sunday after the beginning of April.

On Wednesday 1st of April my Haiku installation started asking whether the time was correct every time I booted. This indicates that the algorith used for detecting the change needs a tweak.

Change History (4)

comment:1 Changed 10 years ago by stippi

I also noticed weird behavior with that, but it seems to be caused by the switch from /boot/beos to /boot/system. Do you happen to have modified your UserBuildConfig like I did and manually placed a link to your correct timezone in there? If so, you may want to adjust the link target to the new location. Does that help?

comment:2 Changed 10 years ago by haiqu

I haven't updated to the new tree structure yet, wanted to wait until most of the bugs were resolved first. :) So this isn't the problem.

comment:3 Changed 8 years ago by Coldfirex

Is this still a problem in recent builds?

comment:4 Changed 6 years ago by scottmc

Resolution: fixed
Status: newclosed

This has probably been fixed over the last 4 years. If it is still an issue then let us know.

Note: See TracTickets for help on using tickets.