Opened 11 years ago

Closed 10 years ago

#3708 closed bug (duplicate)

USB mouse sometimes doesn't work

Reported by: jrepan Owned by: mmlr
Priority: normal Milestone: R1
Component: Drivers/USB Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: #4152 Blocking:
Has a Patch: no Platform: x86

Description

I have Lenovo Ideapad S10e and common USB mouse. Only mouse is connected to USB port. I use hrev29924. Sometimes USB mouse doesn't work, but touchpad works. I dont't know how to reproduce it, it just sometimes doesn't work. Connecting mouse again doesn't help.

Attachments (3)

syslog (239.8 KB ) - added by jrepan 11 years ago.
listusb-when-not-working (335 bytes ) - added by jrepan 11 years ago.
listusb output, when mouse is not working
listusb-when-working (515 bytes ) - added by jrepan 11 years ago.
listusb output, when mouse is working

Download all attachments as: .zip

Change History (5)

by jrepan, 11 years ago

Attachment: syslog added

by jrepan, 11 years ago

Attachment: listusb-when-not-working added

listusb output, when mouse is not working

by jrepan, 11 years ago

Attachment: listusb-when-working added

listusb output, when mouse is working

comment:1 by jrepan, 10 years ago

I discovered that when ACPI is enabled in ~/config/settings/kernel/drivers/kernel then mouse never works. When ACPI is disabled, it seems that now mouse always works.

comment:2 by mmlr, 10 years ago

Blocked By: 4152 added
Resolution: duplicate
Status: newclosed

Then ACPI most probably causes interrupts to be lost. The thing is that ACPI is quite broken for many cases (tracked in #4152), therefore it's not enabled by default. I'm going to close this bug as a duplicate of #4152 as that one should improve the situation on that front, even though it is not actually a duplicate.

Note: See TracTickets for help on using tickets.