Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#3714 closed bug (fixed)

PANIC: ASSERT FAILED (headers/private/kernel/util/DoublyLinkedList.h:467): fFirst != __null && fLast != __null && (fFirst != fLast ||

Reported by: anevilyak Owned by: axeld
Priority: normal Milestone: R1
Component: Network & Internet/Stack Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking: #3748
Has a Patch: no Platform: All

Description

This KDL happened while I was shutting down BezillaBrowser.

Backtrace as follows:

list: 0x80769d48, element: 0x811a1e58
PANIC: ASSERT FAILED (headers/private/kernel/util/DoublyLinkedList.h:467): fFirst != __null && fLast != __null && (fFirst != fLast ||
Welcome to Kernel Debugging Land...
Thread 340 "BeZillaBrowser" running on CPU 0
kdebug> bt
stack trace for thread 340 "BeZillaBrowser"
    kernel stack: 0x98622000 to 0x98626000
      user stack: 0x7efef000 to 0x7ffef000
frame               caller     <image>:function + offset
 0 98625914 (+  48) 8006267d   <kernel_x86>:invoke_debugger_command + 0x00f5
 1 98625944 (+  64) 8006246d   <kernel_x86> invoke_pipe_segment(debugger_command_pipe*: 0x8012e800, int32: 0, 0x0 "<NULL>") + 0x0079
 2 98625984 (+  64) 800627f4   <kernel_x86>:invoke_debugger_command_pipe + 0x009c
 3 986259c4 (+  48) 80063da4   <kernel_x86> ExpressionParser<0x98625a78>::_ParseCommandPipe(0x98625a74) + 0x0234
 4 986259f4 (+  64) 800631de   <kernel_x86> ExpressionParser<0x98625a78>::EvaluateCommand(0x801220a0 "bt", 0x98625a74) + 0x02ba
 5 98625a34 (+ 224) 800651cc   <kernel_x86>:evaluate_debug_command + 0x0088
 6 98625b14 (+  64) 8006056e   <kernel_x86> kernel_debugger_loop() + 0x01ae
 7 98625b54 (+  32) 800613fd   <kernel_x86>:kernel_debugger + 0x004d
 8 98625b74 (+ 192) 800613a5   <kernel_x86>:panic + 0x0029
 9 98625c34 (+  64) 8075e200   </boot/system/add-ons/kernel/network/stack> socket_delete(net_socket*: 0x811a1e58) + 0x00a8
10 98625c74 (+  48) 8075da0c   </boot/system/add-ons/kernel/network/stack> socket_free(net_socket*: 0x811a1e58) + 0x0038
11 98625ca4 (+  48) 8076578d   </boot/system/add-ons/kernel/network/stack> stack_interface_free(net_socket*: 0x811a1e58) + 0x0025
12 98625cd4 (+  32) 800968af   <kernel_x86> socket_free(file_descriptor*: 0x814406b8) + 0x001b
13 98625cf4 (+  48) 8008ec44   <kernel_x86>:put_fd + 0x0038
14 98625d24 (+  64) 8009f898   <kernel_x86> vfs_free_io_context(io_context*: 0x9819661c) + 0x0084
15 98625d64 (+  48) 8009f921   <kernel_x86>:vfs_put_io_context + 0x0029
16 98625d94 (+ 112) 8005497f   <kernel_x86>:team_delete_team + 0x022b
17 98625e04 (+ 192) 800584cb   <kernel_x86>:thread_exit + 0x03af
18 98625ec4 (+  64) 8004cf5d   <kernel_x86>:handle_signals + 0x03d5
19 98625f04 (+  64) 80058948   <kernel_x86>:thread_at_kernel_exit + 0x0090
20 98625f44 (+ 100) 800d8072   <kernel_x86>:kernel_exit_handle_signals + 0x0006
user iframe at 0x98625fa8 (end = 0x98626000)
 eax 0x0            ebx 0x1ac7ad4       ecx 0x7ffeef40   edx 0x246
 esi 0x1acb5c0      edi 0x7ffef544      ebp 0x7ffeef6c   esp 0x98625fdc
 eip 0xffff0104  eflags 0x207      user esp 0x7ffeef40
 vector: 0x63, error code: 0x0
21 98625fa8 (+   0) ffff0104   <commpage>:commpage_syscall + 0x0004
7ffeef6c -- read fault

Possible info of interest:

SOCKET 0x811a1e58
  family.type.protocol: 1.1.6
  parent:               0x00000000
  first protocol:       0x8126e744
  first module_info:    0x90db6d00
  options:              0
  linger:               0
  bound to device:      0
  owner:                223
  max backlog:          0
  child_count:          0

Not sure what else to look up that would be helpful for this one.

Change History (8)

comment:1 by anevilyak, 11 years ago

Component: - GeneralNetwork & Internet/Stack

comment:2 by anevilyak, 11 years ago

The owner of the socket appears to no longer exist, assuming it refers to either a team or thread ID.

comment:3 by axeld, 11 years ago

Is this by any chance a GCC4 build? Because that would be among the consequences of the changes François made to make it build there.

comment:4 by axeld, 11 years ago

Wrong comment: does this by any chance include the broken stuff from François?

comment:5 by adamk, 11 years ago

For what it's worth, I get the same panic when trying to acquire an address via DHCP on a gcc2 build (hrev30085, from the nightly builds, to be exact):

PANIC: ASSERT FAILED (headers/private/kernel/util/DoublyLinkedList.h:467): fFirst != null && fLast != null && (fFirst != fLast

Welcome to Kernel Debugging Land... Thread 97 "/dev/net/broadcom570x/0" running on CPU 0

I can post a full backtrace if necessary.

comment:6 by bonefish, 11 years ago

Blocking: 3748 added

(In #3748) Duplicate of #3714.

comment:7 by axeld, 11 years ago

Resolution: fixed
Status: newclosed

IIRC I've fixed this already, but if not, please reopen.

comment:8 by anevilyak, 11 years ago

I haven't seen it in ages either so most likely fixed.

Note: See TracTickets for help on using tickets.