Opened 10 years ago

Closed 10 years ago

#3771 closed bug (fixed)

'info' in terminal crashes.

Reported by: kvdman Owned by: axeld
Priority: normal Milestone: R1
Component: Applications/Command Line Tools Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Tested on a pre-alpha vmware disk image from haiku-files, and senryu hrev30165.

Please see attached.

Attachments (1)

1.jpg (327.4 KB) - added by kvdman 10 years ago.

Download all attachments as: .zip

Change History (8)

Changed 10 years ago by kvdman

Attachment: 1.jpg added

comment:1 Changed 10 years ago by Adek336

comment:2 Changed 10 years ago by axeld

Component: Applications/TerminalApplications/Command Line Tools
Owner: changed from jackburton to axeld

comment:3 Changed 10 years ago by korli

Seems to be the optional package texinfo-4.13a-gcc2-2008-11-09

comment:4 Changed 10 years ago by axeld

I can't reproduce this over here. Although my "info" certainly doesn't seem to have anything to do with texinfo.

Any updates on this, kvdman?

comment:5 Changed 10 years ago by kvdman

Hi Axel,

I can't reproduce with a fresh Haiku build, please close.

I was getting:

baron@/boot/home>info info: ../gnulib/lib/mbiter.h:161:mbiter_multi_next: *iter->cur.ptr == '\0'

Kill Thread

On personal builds.

Karl

comment:6 Changed 10 years ago by kvdman

btw, it was /boot/common/bin/info not texinfo.

Tested on hrev32528

comment:7 Changed 10 years ago by axeld

Resolution: fixed
Status: newclosed

So this was probably a wchar issue. Thanks for the update, Karl!

Note: See TracTickets for help on using tickets.