Opened 10 years ago

Closed 7 months ago

#3775 closed enhancement (fixed)

List of currently supported HW Drivers

Reported by: egrath Owned by: haiku-web
Priority: normal Milestone:
Component: Website Version:
Keywords: Cc:
Blocked By: Blocking: #10866
Has a Patch: no Platform: All

Description

It would be nice to have a List of all currently supported Hardware viewable on the Haiku Homepage.

Reason: People who want to get into Haiku should have a Quick Overview which Hardware they should put into a (real) Box without the need to dig around in the source to see - for example - if their graphics card is supported.

Change History (8)

comment:1 in reply to:  description Changed 10 years ago by TheNerd

There is already a hardware database at http://www.haikuware.com/hardware-database/. Maybe it could be linked to or something?

comment:2 Changed 10 years ago by JonathanThompson

Version: R1/pre-alpha1R1 alpha1

Ok, so this is the original ticket, and the new one that was a duplicate of this (mostly, anyway) was closed as a duplicate. 5 months ago, having this not be done was mostly a non-issue: however, many people testing out the alpha are asking in the channel "Where can I report working hardware?" or "Where can I find a list of working hardware?" and honestly, it isn't exactly immediately obvious: if you don't already know where all the sites are and what they do, it'll be too much effort for many to search.

If the opportunity to have useful tracking information in a local HCL is going to be ignored, at LEAST someone should add a link into the General FAQ, because people might actually read that! Better yet, why not a link on the front page? I thought the purpose of finally releasing an Alpha 1 to the rest of the real world was to get things reported, but if people have too many barriers to doing that, even if they're the developer types (a lot aren't: they have just enough knowledge of partitioning to be dangerous) then a huge amount of valuable information will be lost, perhaps forever.

comment:3 Changed 10 years ago by mmlr

Well, it's certainly nice to have a list of supported hardware from an end user side of things. But from the developer viewpoint working hardware is pretty uninteresting. The end goal is to have all hardware that is supported by our drivers, to be working. Anything else shouldn't be noted as non-working in some hardware database, but documented as bugs on this bug tracker so the issue can be fixed. I realize that sounds pretty bold, but it's really what we are most interested in right now, things that don't work as expected. If I for example knew that USB works for you, that might give me a "well done" kind of feeling, but if it works for you, then there really isn't anything to do for me, so I don't really need to know.

An easy, automated way of submitting hardware information like you've proposed in the other ticket makes a lot of sense. The important thing is that things flagged non-working need to be properly reported, i.e. cause tickets to be created if they really should be supported by an existing driver. This makes it a bit more complicated. It would be pretty bad if testers would simply flag stuff "non-working" and be done with it, because we then don't get a lot of info that would be possibly be needed. If they create a ticket instead, we have a communication mechanism to ask back for extra information. In the long run, as in when we are heading to R1, we do need an official hardware database so users can check pre-install for the likelihood of Haiku running. For the first alpha though the motto pretty much was "install everywhere and report things that aren't working" rather than a finer grained approach.

If you or anyone has the time to work on such a system, it'd be most appreciated of course, it's just that noone of use managed to pull it off for now. As you noted it is also a two-fold task as in, it needs a Haiku and a web part, which not everyone might be capable of implementing in an efficient way.

comment:4 Changed 10 years ago by nielx

Version: R1 alpha1R1/alpha1

comment:5 Changed 9 years ago by mmadia

Milestone: R1
Version: R1/alpha1

comment:6 Changed 7 years ago by scottmc

There's a wiki for for this now, so we probably just need to link that from the main site and/or download sites to close this out.

comment:7 Changed 5 years ago by luroh

Blocking: 10866 added

comment:8 Changed 7 months ago by waddlesplash

Resolution: fixed
Status: newclosed

Indeed.

Note: See TracTickets for help on using tickets.