Opened 13 years ago

Closed 12 years ago

#387 closed bug (fixed)

FontDemo have some font issues

Reported by: diver Owned by: axeld
Priority: normal Milestone: R1
Component: - General Version:
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description (last modified by korli)

The following labels in FontDemo have starange font. Size, Shear, Rotation, Spacing, Outline.

Attachments (1)

FontDemo.jpg (17.2 KB) - added by diver 13 years ago.
FontDemo

Download all attachments as: .zip

Change History (13)

Changed 13 years ago by diver

Attachment: FontDemo.jpg added

FontDemo

comment:1 Changed 13 years ago by axeld

Owner: changed from bpmagic@… to axeld

comment:2 Changed 13 years ago by diver

Fixed in hrev17064.

comment:3 Changed 13 years ago by diver

Status: newclosed

comment:4 Changed 13 years ago by diver

Resolution: fixed

comment:5 Changed 13 years ago by axeld

Resolution: fixed

comment:6 Changed 13 years ago by axeld

Actually, that shouldn't be able to fix it - only minors the problem.

comment:7 Changed 13 years ago by axeld

Status: closedreopened

comment:8 Changed 13 years ago by diver

Another big thing is that dragging Outline slider will lockup FontDemo and even after you killed it it will stay opened. This happens with several aps from time to time, but in this case it reproducable!

comment:9 Changed 12 years ago by korli

Description: modified (diff)
Platform: All

the Outline slider lockup is fixed in revision 20517. Still one issue is bounding boxes (no rotation, no shear).

comment:10 in reply to:  9 Changed 12 years ago by jfreeman

Replying to korli:

Still one issue is bounding boxes (no rotation, no shear).

I didn't think the bounding boxes was unique to FontDemo. (Italic text in Firefox and Net+ also show up as boxes; thought it had something to do with the font system.)

comment:11 Changed 12 years ago by aldeck

The label issue is fixed in hrev21836, this bug should be closed.

The bounding box issue is a separate ticket, #303

comment:12 Changed 12 years ago by stippi

Resolution: fixed
Status: reopenedclosed

should be fixed since the reimplementation of BFont::GetBoundingBoxesAsString()

Note: See TracTickets for help on using tickets.