Opened 10 years ago

Closed 9 years ago

#3873 closed bug (fixed)

BeZilla only starts when run from Terminal

Reported by: HaiColon Owned by: axeld
Priority: normal Milestone: R1
Component: Applications Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

When starting BeZilla from the Deskbar menu, it crashes and asks if I want to debug it every time I try to run it. When I start it from the Terminal, it starts and works fine nearly all the time, it only crashed one time while starting like it does when using the Deskbar menu. I tried it out about ten times from the Terminal.

I can't say at which revision of Haiku this problem started since I used a different computer to run Haiku up to about a week ago, where I didn't have this problem. I switched computers because the harddisk or one of the fans is damaged in the other computer (it makes evil noises). I did install Haiku to this computer about two months ago though and back then BeZilla did start fine when using the Deskbar menu on this computer.

I'll attach the debugger output of when BeZilla crashes when using the link in the Deskbar menu and the terminal output from the one time BeZilla crashed when started from the Terminal.

I don't know if this could be related but just to be sure, I use the ATA stack instead of the IDE stack because otherwise Haiku only boots on this computer if I disable ide-dma. Id did run jam clean because I read that not doing that can cause problems when switching to the ATA stack.

I'm using revision 30632 of Haiku, gcc2 built from Ubuntu 8.10, installed to an USB harddisk. The computer has a Gigabyte K8NMF-9 motherboard with an Athlon XP 64 3200+ processor and 1,5 Gb of RAM.

Attachments (2)

BeZillaGDBoutput.txt (8.1 KB) - added by HaiColon 10 years ago.
BeZillaTerminalOutput.txt (377 bytes) - added by HaiColon 10 years ago.

Download all attachments as: .zip

Change History (5)

Changed 10 years ago by HaiColon

Attachment: BeZillaGDBoutput.txt added

Changed 10 years ago by HaiColon

Attachment: BeZillaTerminalOutput.txt added

comment:1 Changed 10 years ago by mmadia

does this still happen?

comment:2 Changed 10 years ago by HaiColon

I haven't been using Haiku for a few months after it tried to kill my harddrive if you remember that from IRC mmadia . I bought a new harddrive a week ago so I will try again. I'll have to move stuff around a bit to make one of my older, smaller harddisks free for Haiku so that I won't loose any data on the other harddrives if Haiku still has data loss causing bugs. I'll report back when I had time to try it out.

If it should turn out that the bug is fixed already, would it help if I would pinpoint the revision that fixed the problem by trying out different revisions?

comment:3 Changed 9 years ago by mmadia

Resolution: fixed
Status: newclosed

Assuming this was fixed.

Note: See TracTickets for help on using tickets.