Opened 10 years ago

Closed 10 years ago

#3878 closed bug (fixed)

Faults in haiku-cd build target

Reported by: haiqu Owned by: bonefish
Priority: normal Milestone: R1
Component: Build System Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

Just tried jam -q haiku-cd for the first time.

The build was missing the whole /boot/system directory, and also contained entries in each directory that looked like _HAIKU. This doesn't look right to me.

Of course, because the systems files were missing it couldn't boot either.

Change History (11)

comment:1 Changed 10 years ago by haiqu

I forgot to mention that during the build process there was a warning about the imahe being built not being an iso9660 compatible image. The image could not be mounted within Dano, using mount generated/haiku-cd.iso /image

comment:2 Changed 10 years ago by mmlr

Resolution: invalid
Status: newclosed

Please run an svn diff and check that you don't have any conflicts or changes in your build system. Building the CD works just fine here, under Haiku as well as under BeOS R5 and I know that others build it successfully under Linux as well.

It looks perfectly fine when there are _HAIKU directories. Those are the attribute stores that contain the attributes for the corresponding files.

Also the image is perfectly fine not being fully iso9660 compliant. It just means that the extremely narrowly defined naming and directory depths are not followed strictly. In practice this is not a problem for any system I know of. At least it is not a problem for Haiku, and that's the only real target this CD must work with as you can't really do much with the files on other systems anyway.

That it doesn't mount in BeOS has nothing to do with the image being invalid, but with not using the command correctly. Mounting on BeOS doesn't do filesystem detection. So for anything non-BFS you'll have to provide a "-t <filesystem>" argument. Mounting the CD with "mount -t iso9660 generated/haiku-cd.iso" will therefore work.

comment:3 Changed 10 years ago by umccullough

"svn stat" would probably be a bit faster way to find out :)

comment:4 Changed 10 years ago by haiqu

Resolution: invalid
Status: closedreopened
$ svn stat
M      build/jam/HaikuImage
M      ReadMe
$

I'm going to have to insist that this is a fault. I did it again after fixing a minor syntax error that threw JAM into a complete spin (causing three bogus reports, I might add) but this CD build STILL has no /boot/system directory.

Re comments: Usage details for the mount command aren't very useful, especially when you don't actually know the filetype for the -t switch. And mkisofs issuing a warning when simply building with Rock Ridge or Joliet extensions doesn't make much sense either, especially since plain ISO-9660 is so broken. 8.3 filenames, are they kidding?

comment:5 Changed 10 years ago by stippi

Ok, then please post the output of svn diff build/jam/HaikuImage here. This may either be a fault in your HaikuImage changes, or a problem with using this jam target on BeOS/Dano.

comment:6 Changed 10 years ago by haiqu

There are two minor differences. One is some missing white space, the other is a build target I added, but which is commented out.

~> svn diff /BeOS\ 5.1d0/src/haiku/build/jam/HaikuImage
Index: /BeOS 5.1d0/src/haiku/build/jam/HaikuImage
===================================================================
--- /BeOS 5.1d0/src/haiku/build/jam/HaikuImage  (revision 30645)
+++ /BeOS 5.1d0/src/haiku/build/jam/HaikuImage  (working copy)
@@ -252,7 +252,7 @@
 AddFilesToHaikuImage system servers : $(SYSTEM_SERVERS) ;
 
 # apps
-AddFilesToHaikuImage system                            : runtime_loader Deskbar Tracker ;
+AddFilesToHaikuImage system                    : runtime_loader Deskbar Tracker ;
 AddFilesToHaikuImage system bin                        : $(SYSTEM_BIN) consoled ;
 AddFilesToHaikuImage system apps               : $(SYSTEM_APPS) ;
 AddFilesToHaikuImage system preferences        : $(SYSTEM_PREFERENCES) ;
@@ -460,6 +460,7 @@
        : $(SYSTEM_ADD_ONS_MEDIA_PLUGINS) ;
 AddFilesToHaikuImage system add-ons Tracker
        : FileType-F ZipOMatic-Z Open\ Target\ Folder-T ;
+#      : FileType-F ZipOMatic-Z TarNFeather-R Open\ Target\ Folder-T ;
 AddSymlinkToHaikuImage system add-ons Tracker
        : /boot/system/preferences/Backgrounds : Background-B ;
 AddSymlinkToHaikuImage system add-ons Tracker
~> 

comment:7 Changed 10 years ago by umccullough

Do you possibly have another UserBuildConfig hanging out in your generated folder as well as the trunk/build/jam folder?

comment:8 Changed 10 years ago by haiqu

Nope, and I did a find on that to be absolutely sure.

comment:9 Changed 10 years ago by korli

Just tried myself for the first time, booted correctly in qemu. Fishy.

comment:10 Changed 10 years ago by haiqu

At hrev30690 today and the jam -q haiku-cd target worked fine, all files included in the build and installing to a real HDD also went OK.

Resolved, please close.

comment:11 Changed 10 years ago by stippi

Resolution: fixed
Status: reopenedclosed

Maybe it was hrev30671 which fixed the old IDE stack installation. Thanks for the update.

Note: See TracTickets for help on using tickets.