Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#3879 closed bug (invalid)

HAIKU_IMAGE_SIZE option in UserBuildConfig no longer works

Reported by: haiqu Owned by: bonefish
Priority: normal Milestone: R1
Component: Build System Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

I guess that summarizes it all...

Change History (16)

comment:1 by stippi, 10 years ago

No, unfortunately, it doesn't summarize it enough at all. I am pretty sure that HAIKU_IMAGE_SIZE works, but it may be that it doesn't work for the specific target you are trying to build. So please be more specific about what you are trying to do and about the circumstances that this doesn't work in. (Or rather doesn't work in your opinion...)

comment:2 by haiqu, 10 years ago

# Create a 100 MB image at /tmp/walter.image. HAIKU_IMAGE_SIZE = 320 ;

The image created was 128Mb and changing the value UserBuildConfig didn't alter that.

This worked on my last build within the past 2 days, so something changed.

comment:3 by haiqu, 10 years ago

# Create a 100 MB image at /tmp/walter.image.
HAIKU_IMAGE_SIZE	= 320 ;

comment:4 by stippi, 10 years ago

Are you using jam haiku-image or are you using jam haiku-cd? Because only for the first of these two, the image size is supposed to be settable.

comment:5 by haiqu, 10 years ago

Yes, I knew that.

comment:6 by mmlr, 10 years ago

I don't know what you did to your build system, but FWIW it works fine here.

comment:7 by haiqu, 10 years ago

OK, this was the result of a minor syntax error in UserBuildConfig in a line AFTER the size was set. Jam evidently lost the plot completely.

Close, invalid.

comment:8 by mmadia, 10 years ago

Resolution: invalid
Status: newclosed

comment:9 by umccullough, 10 years ago

I implore you to please discuss your UserBuildConfig issues on the mailing list(s) rather than on Trac.

comment:10 by haiqu, 10 years ago

If it didn't look like a build bug to me I wouldn't report it, Urias. In my own defence, about 8 out of *every* 10 updates I do is rife with bugs included by people who don't actually test code before they upload it. I might add that I was up all night writing a TV card driver, so may not have been as focused as usual.

However, I am getting mighty tired of Trac maintainers assuming I'm an idiot, that all bug reports are automatically wrong (and closing them before investigation) and being condescending. These comments are not specifically aimed at you, btw.

comment:11 by stippi, 10 years ago

Look Rob, I fully understand that feedback to some of your bug reports was frustrating to you overall, but please acknowledge that it may also have been frustrating for the other people involved. I also understand that it's frustrating if there are regressions when you update, though I personally think your "8 out of 10" estimate is totally out of proportion and your reasoning that people don't actually test code is a low blow. It simply so happens that stuff just isn't reproducable on some peoples hardware. For example, the two pre-fetching regressions were not reproducable at first and Axel fixed the issues as soon as he found a setup to reproduce them.

In the future, make it easier on yourself and put more effort into guessing what information may be necessary to look into an issue you report. Instead of assuming/insisting that a particular problem you have must be reproducable on anyones setup, assume that the problem is only reproducable on your specific setup, and then try to provide as much info as possible to replicate that setup, so that the problem becomes reproducable for other people.

I am happy to hear you are working on a TV card driver and am very much looking forward to that.

comment:12 by haiqu, 10 years ago

Stefan, Most of the code faults I'm talking about in updates are not system-specific at all. I'm talking about missing header declarations, missing semicolons (yes, even from your updates) and pretty obvious stuff. And they do happen with great regularity, I wasn't over-estimating the ratio of clean builds to faults. There are also outstanding reports of numerous system-crippling and crashing bugs which apparently no-one has tackled as yet. If you insist on building and operating in a Linux environment, you probably never *will* see them, but I'm using Haiku as a day-to-day development environment now.

It's all very well to take a superior attitude if you're perfect, but none of us are. Going on about how YOUR time is being wasted is ridiculous when you realize that one error in the repository affects everyone who downloads it. Thus, if I see what I think is a fault I report it immediately. Even if I regularly got it wrong 50% of the time the payback in lost developer time would be well worth the effort. On that note, and having already pointed out several times that I'm providing as much information as I either: a) have available, or b) think is relevant to the faults being described, all I can say is that you are again browbeating and lecturing. You have a choice, either accept bug reports or don't, but knock off the damned whining.

On another note: I'm working on a lot more than just a TV card, but don't usually make announcements until I have a working product. But since one of my specialities is DSP and software-defined radio I've been looking into porting an MP4 Enhanced HE-AAC+ (or if you prefer, AAC v2) decoder library. Australia has settled on the DAB standard for radio so I'm going to need that soon.

comment:13 by stippi, 10 years ago

Rob, you obviously lack the mental flexibility to realize that you are even more of a whiner than me. Also, you repeatedly don't give me credit for trying to be polite, so I won't even bother anymore. It only comes across as lecturing to you. My fault for even trying to point out something you could do better. Old people almost never take that well, they are always right and everyone else is the idiot.

So if someone forgets to commit a header it means he has not tested his work? If someone breaks the GCC4 build it means he has not tested his changes on his GCC2 build either, right? And boy how embarrassed I am for commiting that DriveSetup change where I forgot the semicolon. Happens all the time for me personally, I think it's even more than 8 out of 10 times. I should just stop coding, I make life miserable for everyone else by commiting the crap I produce.

-Ste*ph*an.

comment:14 by haiqu, 10 years ago

Stephan, It's always obvious when someone is faking at being polite, so I'm glad to see some honesty at last. I don't know about the old people you associate with, but THIS old person has probably been programming since before you were born, and that you would presume to know enough to advise him is laughable.

If someone breaks the GCC4 build it doesn't matter one whit, that isn't the official compiler right now. You not only forgot a semicolon, you forgot a header DECLARATION (which is different from forgetting to upload the header) in the same file. But I haven't accused you personally of causing 8/10 builds to fail, there are a lot of other people uploading code. The guy working on libavcodec has made a few goofs as well.

As for giving up coding, well maybe ritual suicide would be better. Obviously you don't mean to be taken seriously.

p.s. Sorry about mis-spelling your name, it was unintentional. I had begun to think of you as Stippi, but using your informal name didn't seem appropriate under the circumstances. You see, I even know something about German culture.

comment:15 by stippi, 10 years ago

Thanks for the reply, I was a bit worried I may have went to far...

It is clear to me from your replies that you cannot take critique or even honest polite suggestions at all. It just comes across as lecturing to you and you will not move a millimeter. I am actually a person with great desire for harmony and resolving conflicts. So when I try to be polite it may be because I am trying to discuss on a reasonable level and take away some of the heated emotions so that I may get my point across. Obviously doesn't work with you and I get no credit for it and are just being insulted for feeling superior over others. Your attitude that I couldn't possibly know more than you just says it all. Don't take me wrong, I am not saying that I actually do know more than you, but your attitude just makes it clear why you would never take any advice from me on how you could do something better. Boy, I sure hope I will not be that arrogant and stubborn when I am older.

It probably doesn't work when I try to tell you that my honest intentions were to tell you what you could improve in your communication in the future. Which is that you try to put yourself into other peoples place and try to give them all the information which you can guess they may need, when you try really hard to guess. Like when there is possibly a syntax error in a file you created that you actually post the complete file in the first place and not make other people write three or more comments until they finally get something from you that they can work with. That sort of stuff. And I think with this background, my remark about you wasting precious time with this behavior was long overdue. But instead of simply acknowledging that, you come back with your 8/10 insult and how we morons waste everyones time with our untested work.

comment:16 by axeld, 10 years ago

As entertaining as this dispute is, could you guys please stop using the bug tracker as a message forum?

Note: See TracTickets for help on using tickets.