Opened 10 years ago

Closed 10 years ago

#3924 closed bug (invalid)

Automount of USB stick crashes system to KDL

Reported by: haiqu Owned by: nobody
Priority: normal Milestone: R1
Component: - General Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description (last modified by mmlr)

Assertion failed:

headers/private/kernel/util/DoublyLinkedList.h: 467

fFirst != __null && fLast != __null && (fFirst != fLast ...

Thread 164 "Automounter"

At the time I was installing a large file using the Expander, this might be relevant.

Change History (3)

comment:1 by mmlr, 10 years ago

Component: Drivers/USB- General
Description: modified (diff)
Owner: changed from mmlr to nobody

We really need stack traces for things like that. This is an assertion that is triggered by some code path, but just from the assertion message you cannot tell which.

Is this reproducible? In any case it's not inside USB as USB doesn't use any doubly linked lists. It could be the legacy driver code or filesystem/partitioning related. Without a stack trace it's impossible to tell though.

comment:2 by haiqu, 10 years ago

Easily reproduced here on my Gigabyte GA-7IXE4 mobo. I've had no trouble at all with USB on my Athlon system, but then again I haven't used it much since installing Haiku on the weekend.

Love to help with a stack trace but no way to set that up right now, I'd need a debug terminal because it locks the machine.

comment:3 by axeld, 10 years ago

Resolution: invalid
Status: newclosed

Too little information to be useful, but could be a duplicate of #2690.

Note: See TracTickets for help on using tickets.