Opened 10 years ago

Closed 10 years ago

#3932 closed bug (duplicate)

BFS corrupted during very large project build

Reported by: haiqu Owned by: axeld
Priority: normal Milestone: R1
Component: File Systems/BFS Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: #3150 Blocking:
Has a Patch: no Platform: x86

Description

I have a repeatable fault when at the linking stage of a very large project. The GNU linker LD reports that the filesystem has become R/O at the final linking stage and I have to run chkbfs on the drive from Dano to correct the problem.

Change History (5)

comment:1 by anevilyak, 10 years ago

Component: Drivers/DiskFile Systems/BFS
Owner: changed from marcusoverhagen to axeld

comment:2 by axeld, 10 years ago

Can you provide at least a bit more info? Like what project it is, and maybe a link to it in case it's freely available. A reproducible file system bug would really be nice!

comment:3 by haiqu, 10 years ago

Tried to add data to this report yesterday but the ticket was locked somehow, sorry.

The project was in Pascal so the tools aren't readily available for you to test a build. What I *can* add is that the crash hit EXACTLY as the file size passed a size of 64Mb, which is starting to look like a boundary condition problem. I might also add that my earlier report #3808 about problems creating and copying files and/or writing to CD-ROM occurs at around 32Mb.

comment:4 by haiqu, 10 years ago

While I'm here, I should add that chkbfs run from Dano reported that there were NULL inodes and it took a bit of work to fix the drive. I had to delete large chunks of my work and run chkbfs three times to be sure it was all good again. I was ready to init the partition and start again at one point.

Re-running the compilation on a faster machine caused NO p[roblems, and the eventual executable file size was a whopping 84Mb, is that a record?

comment:5 by axeld, 10 years ago

Blocked By: 3150 added
Resolution: duplicate
Status: newclosed

As this info is not really helpful, I'll just regard it as a duplicate of #3150.

Note: See TracTickets for help on using tickets.