Opened 10 years ago

Closed 10 years ago

#3939 closed bug (duplicate)

IBM z60m backlight not enabled

Reported by: jahaiku Owned by: euan
Priority: normal Milestone: R1
Component: Drivers/Graphics/radeon Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

If I boot haiku on my z60m with a mobile radeon x600 the backlight is not enabled. The backlight will get disabled after the bootup icons have finished and the normal desktop is shown. The shown resolution and picture is OK.

Attachments (1)

z60m_syslog.txt (94.7 KB ) - added by jahaiku 10 years ago.

Download all attachments as: .zip

Change History (4)

by jahaiku, 10 years ago

Attachment: z60m_syslog.txt added

comment:1 by scottmc, 10 years ago

Here's a similar report on a linux mailing list that might help in debugging this: http://osdir.com/ml/linux.acpi.ibm-acpi.devel/2007-11/msg00033.html

comment:2 by leavengood, 10 years ago

I can confirm this (as I have this exact laptop, using it now in fact) though I did not test it recently. I think I logged this as another bug too, which I'll try to find.

comment:3 by leavengood, 10 years ago

Resolution: duplicate
Status: newclosed

I found the other bug, which I logged about a year ago: #2675. I started looking through the messages Scott linked to, but since then the X.org Radeon code has changed a lot. When it comes to drivers I don't know what I'm doing, and I'm not sure what to change in our driver to make it work. But I may keep looking at it since I like this laptop and would like it to work with Haiku. Though I guess there is always VESA mode...

Anyhow, I'm closing this bug as a duplicate.

Note: See TracTickets for help on using tickets.