Opened 10 years ago

Closed 10 years ago

#3940 closed bug (fixed)

Can't install from CD at r30790

Reported by: haiqu Owned by: axeld
Priority: normal Milestone: R1
Component: - General Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

Just did my first native build on an Athlon 64 3000+ at hrev30790 and the CD wouldn't get past the rocketship icon, even using Safe Boot. I reverted my code to the last known good build which is hrev30782 here, and retried with success.

Recent changes to Path.cpp might be the cause.

Change History (9)

comment:1 Changed 10 years ago by bonefish

Component: Build System- General
Owner: changed from bonefish to axeld

Please only select a component, if it might actually have something to do with the reported bug. If your best guess is BPath changes, then "Build System" is definitely the wrong component. And no, "Build System" is not the fallback component, just because everything is built by the build system.

comment:2 Changed 10 years ago by VinDuv

Do you use any optional packages ? I noticed the same behaviour when creating a CD image with many of them included.
The last line of the serial log was something like "cannot start /bin/sh, error = -1". Maybe a file number limit is hit somewhere...
In your case, some files may have been added to the build between hrev30782 and hrev30790, and made the limit reached.

comment:3 Changed 10 years ago by haiqu

Invalid. Problem was caused by a faulty unused 30Gb hard drive, which is now junk.

comment:4 Changed 10 years ago by axeld

Resolution: invalid
Status: newclosed

Thanks for the update!

comment:5 Changed 10 years ago by haiqu

Resolution: invalid
Status: closedreopened

Reopened. I have just done a CD install from a Dano build of hrev30782 to a known good drive, then built a clean installation CD (deleting generated/objects first) and tried to boot hrev30790. It wouldn't boot.

comment:6 Changed 10 years ago by haiqu

Reverted to hrev30786 and rebuilt and the CD booted. Saved Path.cpp and Path.h then did svn up -r30805 and reinserted Path.cpp and Path.h and rebuilt. The CD booted and installed fine.

The problem is definitely in that change. Over to you, Axel.

comment:7 Changed 10 years ago by haiqu

BTW it may be relevant that I'm still using the IDE bus manager, not the ATA manager. My hard drives are all SATA on this newer machine too. Hope that sheds some light on the issue.

comment:8 Changed 10 years ago by haiqu

Confirmed fixed as at hrev30914.

comment:9 Changed 10 years ago by mmadia

Resolution: fixed
Status: reopenedclosed

thanks for the confirmation!

Note: See TracTickets for help on using tickets.