Opened 10 years ago

Last modified 23 months ago

#3946 assigned bug

automount weirdness: creates symlink at mount point

Reported by: jonas.kirilla Owned by: nobody
Priority: normal Milestone: R1
Component: - General Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Running Haiku off harddisk (hrev30806 and hrev30823 on two different machines) I tried plugging a USB stick to which I had dd:ed a BFS image. (IIRC a haiku.image, from some April 12 revision, if the below output is to be trusted.)

No volume appeared, but Tracker's mount menu showed the volume as mounted. I tried to unmount but the volume remained checkmarked in the mount menu. Wondering what was up I turned to Terminal and had a look at the filesystem mount points.

After USB stick insertion and Tracker r/w dialog answered, the following symlink appears at /:

/> ls -al 
 ...
lrwxrwxrwx 1 baron root   30 Apr 12 21:17 Haiku1 -> /boot/system/preferences/Media
 ...

A symlink is unexpected. The link target is just puzzling. Its permissions deviates from the other symlinks at the fs root.

After removal of USB stick:

/> ls -al 
 ...
drwxr-xr-x 1 baron root    0 May 21 22:06 Haiku1
 ...
/>

Now we're back to a folder for the mount point. (Created before the symlink and covered by it, now revealed again?)

See attached file for full output.

I don't think I can reproduce this anymore. Having dd:ed a later Haiku revision to the stick, Haiku crashes in the "bfs block allocator". (Worn out flash maybe?)

Attachments (1)

ls_output.txt (1.9 KB) - added by jonas.kirilla 10 years ago.

Download all attachments as: .zip

Change History (2)

Changed 10 years ago by jonas.kirilla

Attachment: ls_output.txt added

comment:1 Changed 23 months ago by axeld

Owner: changed from axeld to nobody
Status: newassigned
Note: See TracTickets for help on using tickets.