Opened 10 years ago

Closed 10 years ago

#3947 closed bug (fixed)

Optional Package: p7zip - archive seems to contain wrong permissions

Reported by: rossi Owned by: axeld
Priority: normal Milestone: R1
Component: - General Version: R1/pre-alpha1
Keywords: Cc: haiku@…
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

The p7zip optional package seems to contain some wrong permissions. At least the tempory files created during the build cannot be removed (unless using sudo of course). You can also see the errors generated during the build in the attached log.

Attachments (3)

error-30824M.log.zip (52.7 KB) - added by rossi 10 years ago.
p7zip.OptionalPackages.diff (718 bytes) - added by scottmc 10 years ago.
p7zip.OptionalPackages.2.diff (718 bytes) - added by scottmc 10 years ago.
new zip file with a new date, hopefully this one works better for deleting the files after the build

Download all attachments as: .zip

Change History (9)

Changed 10 years ago by rossi

Attachment: error-30824M.log.zip added

comment:1 Changed 10 years ago by luroh

Confirmed. Building gcc2 on Ubuntu 9.04 32-bit.

Changed 10 years ago by scottmc

Attachment: p7zip.OptionalPackages.diff added

comment:2 Changed 10 years ago by scottmc

Cc: haiku@… added

Not sure what's up with this as I thought I built this the same as all the others I've done. Try applying the attached patch and see if the newer zip file is any different.

comment:3 Changed 10 years ago by luroh

Nope, sorry. The problem still seems to be wrong permissions of the folder generated/tmp/unzip/common/share/doc/p7zip/DOCS and the files inside it.

Changed 10 years ago by scottmc

new zip file with a new date, hopefully this one works better for deleting the files after the build

comment:4 Changed 10 years ago by luroh

yep, that one did the trick :)

comment:5 Changed 10 years ago by scottmc

This one can be closed, it was fixed with hrev30915.

comment:6 Changed 10 years ago by mmadia

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.