Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#3968 closed bug (fixed)

Can't install from CD at r30851

Reported by: haiqu Owned by: axeld
Priority: normal Milestone: R1
Component: File Systems Version: R1/pre-alpha1
Keywords: Cc: marcusoverhagen
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

Gets to the rocketship icon and locks up. This is not the same fault reported in #3940, I already patched that fault.

Tested on two machines.

Install works at hrev30849 so that should help narrow the problem.

Change History (5)

comment:1 Changed 10 years ago by marcusoverhagen

Cc: marcusoverhagen added

Does reverting the hrev30851 changes fix it? Does removing the firewire driver fix it? Does pressing F12 drop to KDL? please provide bt.

comment:2 Changed 10 years ago by mmlr

Is this fixed by hrev30876?

comment:3 Changed 10 years ago by haiqu

Confirmed fixed as at hrev30914

comment:4 Changed 10 years ago by mmadia

Resolution: fixed
Status: newclosed

Thanks for the confirmation!

comment:5 Changed 10 years ago by mmlr

Just to clarify, this wasn't a regression. Support for relocated directories has been missing from our iso9660 fs all along. That a CD would be rendered unbootable was caused by the rr_moved pseudo-directory being placed before vital directories in the ISO root directory. This could have been caused by using a different mkisofs or by simply using different build targets or options. If you first built without perl for example it is likely that no relocated directories were created at all, as the directory depth didn't require it. In that case, mentioning those differences in build options or host tools would have been useful in pinpointing the cause down.

Note: See TracTickets for help on using tickets.