Opened 13 years ago

Closed 13 years ago

#397 closed bug (fixed)

System lockup when hitting ctrl-c in playfile

Reported by: adamk@… Owned by: axeld
Priority: normal Milestone: R1
Component: System/Kernel Version:
Keywords: Cc: diver
Blocked By: Blocking:
Has a Patch: no Platform: All

Description (last modified by axeld)

If I'm playing an mp3 file with playfile, and hit 'ctrl-c' to stop it, I get a complete system lockup.

Attachments (2)

playfile-lockup.txt (46.2 KB) - added by adamk@… 13 years ago.
Debug information
haiku-playfile-lockup.txt (68.0 KB) - added by adamk@… 13 years ago.
Lockup debug info.

Download all attachments as: .zip

Change History (11)

comment:1 Changed 13 years ago by adamk@…

* Bug 398 has been marked as a duplicate of this bug. *

comment:2 Changed 13 years ago by adamk@…

rep_platform: AllX86

comment:3 Changed 13 years ago by adamk@…

op_sys: AllHaiku

Changed 13 years ago by adamk@…

Attachment: playfile-lockup.txt added

Debug information

comment:4 Changed 13 years ago by diver

Cc: diver added

comment:5 Changed 13 years ago by korli

bug_group: developers

comment:6 Changed 13 years ago by korli

Please could you check if it still happens ?

comment:7 Changed 13 years ago by adamk@…

Yeah, it's still happening with build 17386. I'll create a new attachment, just in case it'd be helpful.

Changed 13 years ago by adamk@…

Attachment: haiku-playfile-lockup.txt added

Lockup debug info.

comment:8 Changed 13 years ago by axeld

Component: ApplicationsSystem/Kernel
Description: modified (diff)
Owner: changed from sikosis to axeld
Platform: All

comment:9 Changed 13 years ago by axeld

Description: modified (diff)
Resolution: fixed
Status: newclosed

This was probably the same as bug #702, and was fixed in hrev18683. At least I can't reproduce it anymore.

Note: See TracTickets for help on using tickets.