Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#3994 closed bug (duplicate)

Installation fails at r30960

Reported by: haiqu Owned by: bonefish
Priority: normal Milestone: R1
Component: Applications/Installer Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: #3978 Blocking:
Has a Patch: no Platform: x86

Description

Just did my usual svn up and CD burn for the day. Installation fails at demangle with the message:

Error: is a directory

It doesn't say what exactly is a directory, so I assume the name is blank. Worked fine at hrev30946 yesterday.

Change History (11)

comment:1 Changed 10 years ago by bonefish

Blocked By: 3978 added
Component: Build SystemApplications/Installer
Resolution: duplicate
Status: newclosed

First of all: Please refrain from setting the component to Build System unless it is a problem that happens while running configure or jam!

The offending directory is /system/add-ons/kernel/debugger/demangle. Apparently the installer doesn't remove anything which is in the way. Closing as dup of #3978.

comment:2 Changed 10 years ago by haiqu

Actually it's a different issue. This time a directory was in the way where a file was going to be placed, c.f. a link in #3978.

And btw, since you apparently disagree with my choice of settings, perhaps you could suggest a more relevant one. The Installer works fine, and that's the only other related component.

comment:3 Changed 10 years ago by anevilyak

Except the Installer doesn't work fine, since it's precisely the component that's failing to correctly detect the presence of a conflicting filesystem object, so yes it's very much a duplicate of #3978, and yes it's the correct component. The build system has nothing whatsoever to do with this problem.

comment:4 Changed 10 years ago by stippi

Yes, it is in fact the Installer which needs to be fixed. I broke this when I changed the copy routine. When clobbering regular files, or when the directory layout does not change, overwriting worked, but I didn't test with stuff "in the way" like in these situations. I did wonder if I should completely purge the system folder, I think this would be cleaner, since it should not contain user modifications. Obviously in this mode it should not purge the home folder, but maybe "develop" is another good candidate to be purged. Maybe a requester could simply ask the user, which may also leave a better feeling about what exactly is going on when installing to an existing partition without initializing it first.

comment:5 Changed 10 years ago by haiqu

Stippi,

Asking the user is the option I'd prefer. Especially since purging the develop folder would clobber the GCC compiler (which I refuse to relocate, there wasn't any point to that) and my Pascal compiler.

But I disagree that it was a fault with the installer. The person who made changes that required directories to be removed didn't liaise with you about it before blundering ahead. On more than one occasion.

comment:6 in reply to:  5 Changed 10 years ago by anevilyak

Replying to haiqu:

But I disagree that it was a fault with the installer. The person who made changes that required directories to be removed didn't liaise with you about it before blundering ahead. On more than one occasion.

That might actually be a concern when we have releases to install between. Frankly I doubt anyone other than you cares if the installer doesn't gracefully handle going from one bleeding edge SVN revision to another. Going from Haiku 1.0 to Haiku 1.1 is however a different story.

comment:7 Changed 10 years ago by haiqu

You're quite right, of course. Je suis un vieux bâtard désagréable. However, it may surprise you to review just how close we are to that release, and it behooves the developers to get into the right mindset earlier rather than later.

The situation will become intolerable when there are more than 100 Haiku users. And I do think that might actually happen if we had less broken versions. ;]

Robert

comment:8 Changed 10 years ago by anevilyak

I'm not very surprised at all, I've been running it more or less exclusively on one of my boxes for close to a year now. Nevertheless, my point about it being unrealistic to expect the installer to cope with upgrading between any two random SVN revisions stands, and I might also note, my experiences with beta testing OSes from various commercial companies indicate no one else bothers to support this either. At least every time I've been in an OS beta testing program it was quite explicitly suggested to reformat between builds rather than attempting the usual setup upgrade.

comment:9 Changed 10 years ago by haiqu

Perhaps when we - like Microsoft - have 10 million beta testers, we can afford to annoy a few of them. OTOH Haiku needs all the users it can get. My fondest memory of beta testing was on Netscape 2.x where every comment was regarded as valuable input.

As for reformatting between installs, that's a bit extreme. Unless you have to kill off a registry, of course.

comment:10 Changed 10 years ago by mmadia

Rob, you need to re-acquaint yourself with our BugTrackerEtiquette

You have repeatedly broken numerous of the rules put forth. From re-opening tickets that were marked closed-->invalid, only to have them re-closed. To personally insulting contributors to the project. To insisting the developers are responsible for user errors. To adding comments that have little or nothing to do with the ticket.

This ticket was marked Closed-->duplicate over a day ago and you still feel a need to comment on it.

comment:11 Changed 10 years ago by haiqu

And you already know what I think of *your* opinion.

Note: See TracTickets for help on using tickets.